Multiple Email Problem

Soulquarian

Member
Bronze
Jul 2, 2007
38
0
6
#1
Hey guys, I have 4 email accounts and I keep having a problem when replying to them.

My primary account is a businesss one, however, when I reply to emails in any of the other 3, even when making sure to be replying from an email address other than the primary, the email is sent from my primary businesss account.

This is not good at all...

Any suggestions?

Strangely enough, when I pull up Gmail on my laptop, it shows that it was sent from the email address I intended, even though the person replied to the primary...
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#2
You've got one email address set as the default. When you reply from your iPhone, it automatically sends it from the default email address.

Go to:

Settings>Mail>Sending>Default Account
 

chris

Administrator
Administrator
Jun 10, 2006
11,813
1,779
113
Long Island, NY
#3
I had a similar issue and the only resolution was to go through Safari. In Gmail, it will reply from the address it was sent to, rather than on the iPhone Mail client which uses the default.

Sorry if that doesn't make sense. FWIW, I have the same issue on the desktop. If I use Mail, i often reply to someone from my Gmail account rather than one of my 'everything' accounts.
 

Soulquarian

Member
Bronze
Jul 2, 2007
38
0
6
#4
I had a similar issue and the only resolution was to go through Safari. In Gmail, it will reply from the address it was sent to, rather than on the iPhone Mail client which uses the default.

Sorry if that doesn't make sense. FWIW, I have the same issue on the desktop. If I use Mail, i often reply to someone from my Gmail account rather than one of my 'everything' accounts.

I figured as much, and that's really inconvient.

Hopefully Apple fixes this, or someone comes up with a workaround with the SDK...
 

joeg679

Member
Bronze
Jul 18, 2007
391
0
16
#5
I had the same problem. I have a businesss account, an aol account, a gmail account and a yahoo account. My aol is the default, but that only means that if i compose an email from anything other than the email program, it comes from AOL (eg. a "contact us" link on a webpage). I would receive emails in the other accounts and when I replied, it came from my aol, I even deleted the aol account off my iPhone, but it still did it. Apple told me to plug the phone into iTunes and restore it and when I did, it worked perfectly. I hope this helps.
 

Snoozie

New Member
Jul 29, 2008
1
0
0
#6
I had a similar issue and the only resolution was to go through Safari. In Gmail, it will reply from the address it was sent to, rather than on the iPhone Mail client which uses the default.

Sorry if that doesn't make sense. FWIW, I have the same issue on the desktop. If I use Mail, i often reply to someone from my Gmail account rather than one of my 'everything' accounts.
I've also ran into this problem. I ended up setting up my 2 other accounts as well as my gmail account on my iPhone. Then if I just use gmail to check my email (I already had gmail set to check my other accounts), when I go to reply it now shows the 'from' email address. If you click on it, it brings up a drop down and you can select one of your other email addresses to send from. This only works if you have all of your accounts set up as mail accounts. But at least now I can just use my gmail to check, reply and compose emails from any of my email addresses without having to go through Safari.
 

roritor

New Member
Aug 7, 2008
1
0
0
#7
Ok, guys, I just had the same problem myself but I figured it out. It's actually very simple.
A friend of mine just bought an iPhone so he gave me his iPod Touch. I love it! :laugh2:
Anyway, the problem lies not in the default mail account but in the default smtp (outgoing mail) server information specified. Regardless of how many mail accounts you have or which one you have set for default, the smtp server you have specified is the server that the iPhone or iPod Touch will use to communicate with to send out your email.
The way you can view/edit this information is:

Go to main page, then:

Settings --> Mail, Contacts, Calenders --> Mail Account (in my case, gmail) --> scroll down and click on 'SMTP' --> Primary Server --> here you can specify any/all settings you need including server, user name, password, etc.

Worked for me!

Good luck...