My icons randomly move around in 2.2

salar101

New Member
Dec 9, 2008
13
0
0
#1
Hey guys,
I have a iPhone 3G 2.2 jailbroken, and after each restart app icons move around randomly. Dose anybody knows how can I fix this?:oops:
(I don't have kate either installed which seems to be the cause of this problem)
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#2
I've never heard of this, but something that's worth a shot:

If you have bossprefs or SBsettings installed, go into the "extras" and "fix user directory permissions." I'm just guessing, but it could be that the folder where your desktop layout is stored got its write permissions messed up somehow. Anyway, there's little harm in trying.
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#3
Hey guys,
I have a iPhone 3G 2.2 jailbroken, and after each restart app icons move around randomly. Dose anybody knows how can I fix this?:oops:
(I don't have kate either installed which seems to be the cause of this problem)
I've noticed that my icons will start wigglin' when I try to use an app/program. This just started a couple of days ago.... maybe time for a new restore and jailbrake

My lag is back and bigger than ever, by the way Psylichon....what about yours? Any returning lag?
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#4
Welcome back, Buford.

Yeah it's there. Not as bad as 2.1, but it does build up to annoying levels still. I've found a quick respring from SBsettings solves it, though. No reboot necessary.
 

salar101

New Member
Dec 9, 2008
13
0
0
#5
I don't have either of bosspref or sbsetting. I guess i have to go with a restore :((
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#6
I don't have either of bosspref or sbsetting. I guess i have to go with a restore :((
You said you're jailbroken, right? Those apps are free... get SBsettings from Cydia, it's really cool.
 

salar101

New Member
Dec 9, 2008
13
0
0
#7
So would this be solved if i use sbsetting?
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#8
I don't know... but it's worth a shot.
 
Jun 19, 2007
33,493
4,550
113
Upper Marlboro, MD
#10
I've noticed that my icons will start wigglin' when I try to use an app/program. This just started a couple of days ago.... maybe time for a new restore and jailbrake

My lag is back and bigger than ever, by the way Psylichon....what about yours? Any returning lag?
My icons started doing that as well a couple days ago, OJ. I was also having trouble with Safari remembering login information for various sites.

I seemed to have cured both problems by opening SBSettings and selecting "Fix User Permissions.' The iPhone has worked fine since then. It might save you a needless restore.