My iPhone doesn't like to charge anymore :(

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Nikos

New Member
Bronze
Sep 14, 2007
149
0
0
Long Island, NY
www.nikostoscani.com
#1
Hey guys, I have an iPhone with 1.1.2 FW (unlocked and jailbroken), though this started before I updated to 1.1.2 so that may not be relevant.

Anyway, I'm having some issues charging my phone. I use a Griffin TuneFlex in the car. Previously, my phone would charge whenever I connected it to the TuneFlex. Now it doesn't. The phone still recognizes the TuneFlex, it just doesn't charge.

Also, when I connect it to my PC, via the USB cable, it doesn't charge. In fact, my PC doesn't even recognize the phone. Sometimes I will hear the sounds that play when you connect and disconnect a USB device, as if I'm periodically connecting/disconnecting the phone.

If I plug the phone into the wall it charges fine. Also, if I plug it into my MacBook (via USB) it charges as well.

Any ideas? This happened out of nowhere. Any and all help would be much appreciated!
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
30
Atlanta, Georgia
#2
I would assume the 3rd party software as well as the fact that it is unlocked may have something to do with the problems you're receiving. Did you unlock and jailbreak the phone yourself? If so, I would suggest restoring and trying it all over again and hopefully that will fix the issue.
 

coolie

New Member
Bronze
Sep 18, 2007
131
0
0
#3
You should try to do a restore to see if it's fixed or not. If not, then you should bring it back to Apple store and tell them about your problem.
 

Nikos

New Member
Bronze
Sep 14, 2007
149
0
0
Long Island, NY
www.nikostoscani.com
#4
Thanks guys, I guess I'll try a restore. Does that reset my usage statistics? I forget.

Something worth noting, I just disconnected it from my PC. The whole time, ti didn't say it was charging. The battery showed about 10% and it stayed on. I figured it was getting power, but not enough to charge. When I disconnected it, the battery meter shot up to about 60%, so I guess it was charging but not showing it.

Is it safe to restore unlocked 1.1.2? I just updated the other night and haven't read up on it. Going to do so now ;]
 

maf2003

New Member
Sep 24, 2007
26
0
0
#9
Hey guys, I have an iPhone with 1.1.2 FW (unlocked and jailbroken), though this started before I updated to 1.1.2 so that may not be relevant.

Anyway, I'm having some issues charging my phone. I use a Griffin TuneFlex in the car. Previously, my phone would charge whenever I connected it to the TuneFlex. Now it doesn't. The phone still recognizes the TuneFlex, it just doesn't charge.

Also, when I connect it to my PC, via the USB cable, it doesn't charge. In fact, my PC doesn't even recognize the phone. Sometimes I will hear the sounds that play when you connect and disconnect a USB device, as if I'm periodically connecting/disconnecting the phone.

If I plug the phone into the wall it charges fine. Also, if I plug it into my MacBook (via USB) it charges as well.

Any ideas? This happened out of nowhere. Any and all help would be much appreciated!

I had the same problem i think. ill would plug it in and it seems to be charging but no change in the battery meter. but if u turn the phone off and on then it would show. there are only 3 things that it could be for me, i installed summerboard 3.0, all sources, and i use a cheap after market wall charger. i had to virginiz/restore to 1.1.1 and back to 1.1.2(unlocked) ive didn't install SB3.0 or all sources from installer and i don't use the cheap charger anymore and mine seems to show the batter going up now. before i virginiz/restore and drain the batter as much as i could. had edge/wifi/ssh/bluetooth on and brightness to max and playing music with full volume and auto lock set to never and battery drain to where the phone ask you to plug to power in 2hrs from almost full battery(i think). now im stilling on unlocked 1.1.2 with no summberboard and only installer and service as apps. i only use the Apple charger now and it seems to work now. hope that helps. over all if i had to pick the problem i would say it was the cheap charger. but ill wait a bit more to see if the battery stays good before installing apps again.

Im not saying your charger is cheap but it could be bad. just try the Apple charger for now and see what happens
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#10
I would say that your jailbreaking and/or unlocking is the culprit here.

However, if Restoring does not seem to help, then check your USB port on the phone for any lint, dust, etc. If a certain amount gets in there, it may prevent charging. If there is any in there, try to (gently) get it out with either a toothpick or paperclip.

- John
 

KNK

New Member
Jul 22, 2007
2,391
1
0
Stevenson Ranch
#11
And Like PacManPro said I have even used a vacumn cleaner to suck it clean, even the ear portion and mic and speaker portion, lots of lint in your pockets, which is where mine mostly is.