My iPhone won't ring

bavman

New Member
May 5, 2008
19
0
0
#1
When my iPhone is resting or locked and i have an incoming call the phone doesn't ring or vibrate like its supposed to, but if its in the charger or im using it, it does ring when i have an incoming call...any ideas?
 

chcorey52

New Member
Silver
Dec 25, 2007
556
0
0
#2
try reseting general settings? im pretty sure
 

bavman

New Member
May 5, 2008
19
0
0
#3
try reseting general settings? im pretty sure
nope didn't do anything...when i called myself it didn't ring so i unlocked the phones then all my bars went out and it said NO SERVICE and after i hung up all my bars came back and it said i had 1 missed call..i don't nknow why it keeps doing this
 

chcorey52

New Member
Silver
Dec 25, 2007
556
0
0
#4
wow sounds like its a time for a restore....you should prob set up as new also so you don't have the same prblem again
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,385
1,089
113
DC
#5
well, you won't be able to receive calls if your iPhone is accessing data through edge.

sounds like that may be the issue.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#6
well, you won't be able to receive calls if your iPhone is accessing data through edge.

sounds like that may be the issue.
Good call.

Are you jailbroken? If so, use BossPrefs to turn off the Edge antenna and see if that helps.
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,385
1,089
113
DC
#7
except I just noticed he said he has this problem when it's locked too.

curious...
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#8
When it locks it switches off wifi and goes to edge. If he docks it in the vicinity of wifi, then it will never be on edge when docked and lit up. Could be some sort of rogue app trying to constantly access the internet?
 

snavemit

New Member
Sep 3, 2007
2
0
0
#9
Try ejecting your SIM card and then make sure that it is seated properly. I had a similar issue and this solved the problem.
 

bavman

New Member
May 5, 2008
19
0
0
#11
Well i have tmobile and it always displays the EDGE sign, but when i turn it off using bossprefs it still displays it.