My new iPhone won't find my WiFi network

  1. Spiritz

    Spiritz New Member

    Joined:
    Dec 27, 2008
    Likes Received:
    0
    Hello,
    My new iPhone won't find my home wifi network... It just don't appear in the network list.:(
    And my network is not securized at all...
    If someone could help me...
    Thank you !
     
    #1
  2. PepeRB29

    PepeRB29 New Member

    Joined:
    Mar 21, 2008
    Likes Received:
    0
    #2
    Last edited by a moderator: Mar 18, 2014
  3. Avatar

    Sponsored Advertisement

  4. showguy

    showguy Member
    Silver

    Joined:
    Dec 2, 2007
    Likes Received:
    15
    Try the following steps:

    1- Make sure the wireless network setting on your iPhone is on.
    2- Shut iPhone off
    3- Shut modem off
    4- shut wireless router off

    In this order do the following:

    1- Turn modem back on and wait for all the normal lights to turn on and steady
    2- Turn router on and wait for all the normal lights to turn on and steady

    3- Turn iPhone back on.

    This procedure may help if the router and the iPhone where having a difficult time agreeing on an IP address

    Good luck
     
    #3
  5. acosmichippo

    acosmichippo Genius
    Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    1,048
    doesn't sound like getting an IP was the problem (as it doesn't even see the network), but it's worth a shot.

    maybe it's an 802.11n-only network?
     
    #4
  6. Spiritz

    Spiritz New Member

    Joined:
    Dec 27, 2008
    Likes Received:
    0
    thanks

    Hello,
    Thank you for your answer. I looked back before I wrote this quote... Of course... And the quote you sent me has no relation with my problem...
    Thanks anyway !


     
    #5
    Last edited by a moderator: Mar 18, 2014
  7. styfle

    styfle Zealot
    Gold

    Joined:
    Mar 31, 2008
    Likes Received:
    7
    what router do you have?
     
    #6
  8. Spiritz

    Spiritz New Member

    Joined:
    Dec 27, 2008
    Likes Received:
    0
    Hello,
    Thank you ! I think you understand my problem ! True, my home wifi is just not recognized by my I phone. It doesn't even recognize the routers of my neighbours...
    The modem/router I have is a Linksys WAG325N.
    Sorry, I don't really understand if it's 802.11n only network... Maybe yes, but what does it mean ?
    Thank you for your time !

     
    #7
  9. styfle

    styfle Zealot
    Gold

    Joined:
    Mar 31, 2008
    Likes Received:
    7
    Theres your problem. Thats a N router so hopefully it has G also or else you wont be able to connect with your iPhone. I'm not sure if you know the username and password to your router but go to 192.168.1.1 using your browser on your computer. Then try admin for both username and password unless you know what it is. Then click wireless and choose Mixed N and G.
     
    #8
  10. Spiritz

    Spiritz New Member

    Joined:
    Dec 27, 2008
    Likes Received:
    0
    Hello,
    Thanks for your advices !
    In fact, my router was already on mixed mode. But I re-did the setup of my router. I only changed one parameter : The name of my network. There was a "é" in the name. I believe it was the problem...
    Thank you for you brilliant help !:)


     
    #9
  11. kenneth

    kenneth Zealot
    Gold

    Joined:
    Aug 19, 2008
    Likes Received:
    0
    I had to call linksys and get them to reset, update, and test everything to get my iPhone to connect to my home wifi. Why won't a N router work? I was thinking about getting one for the speed boost and the range booster.
     
    #10
  12. Tug

    Tug Member
    Silver

    Joined:
    Aug 4, 2008
    Likes Received:
    0
    I was just going to suggest calling Linksys, they have pretty good support and their open 24/7.
     
    #11
  13. nerd

    nerd New Member

    Joined:
    Dec 28, 2008
    Likes Received:
    0
    I've had trouble using a password with my Linksys router. Tried all the protocols (WEP, WPA, WPA2, etc). If you keep getting "unable to join" on your iPod touch/iPhone, you might try using a MAC filter instead of setting a password on your router. This is under "Wireless Settings" in the Linksys setup page, accessed by typing your IP address into your browser. The router can automatically detect the MAC addresses of devices trying to access the network, so you shouldn't need to go dig up the MAC addresses (although I had to manually enter my Tivo MAC address). Select "Enable", "Edit MAC Filter List", "Wireless Client Mac List", and "Permit only". Hope someone finds this helpful.
     
    #12
  14. acosmichippo

    acosmichippo Genius
    Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    1,048
    an 802.11n router will work just fine as long as it is set to create a "mixed" g/n network. If it creates an n-only network, g-devices won't see it. The benefit of creating an n-only network is that it'll be faster than a mixed one.
     
    #13
  15. mbs3

    mbs3 New Member

    Joined:
    Oct 23, 2010
    Likes Received:
    0
    Possible fix For wifi detection problem

    Hi I had this problem and tried everything that i found and it never work. But i finally got it and what happened was i had gotten my phone and restored it but forgot to set my email up... i tried for 3 days to get my wifi to work restored 2 more times reset the network settings 3 times even tried renaming the ssid name but nothing! then I realized my email wasn't set up, so i quickly did that over 3g then the wifi appeared and is working awesome now. So just make sure email is set up and if its not that may be your problem...if not it may be a hardware defect with the antenna and if you still have your warranty it should be covered to replace or be fixed by Apple
     
    #14
  16. iP5

    iP5 Evangelist
    Gold

    Joined:
    Sep 7, 2010
    Likes Received:
    150
    Wow. There's a bug requiring email to enable wifi in some units?

    Sent from my iPhone using iCafe app
     
    #15
  17. acosmichippo

    acosmichippo Genius
    Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    1,048
    not that i've heard. could be a fluke incident.
     
    #16
  18. JamesMB

    JamesMB New Member
    Bronze

    Joined:
    Dec 14, 2008
    Likes Received:
    0
    Email, has absolutely nothing to do with whether wifi will enable/connect.
    I have 2 iPhones, one with email, and one without, and wifi works on both of them just fine.


    Sent from my iPhone using iCafe
     
    #17
  19. Lon

    Lon Evangelist
    Gold

    Joined:
    Jun 5, 2010
    Likes Received:
    127
    I agree. Though I just a similar experience with my son's WiFi. It wouldn't let me on even though my iPhone recognized it. After fiddling with it for half an hour I accidentally hit my email. The iPhone immediately prompted me to enter the password and join! Strange.
     
    #18

Share This Page