Need advice on udating the firmfare

Dec 9, 2009
26
0
6
#1
Guys rite now I am in 3.1.2 firmware(3Gs) and I want to upgrade it now. So can you please tell me which firmware as well as i-tunes is safer for jailbreak & unlock. Also I have SHSH blobs from 3.1.2 to 4.2.b3. P.S I don't want tethered jailbreak. BTW I tried restore to 4.3.3 but I am getting "Apple update server error or timeout error".Whats going wrong?. Thanks in advance
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#2
Apple is no longer "signing" that firmware, that is why you get the error message. If it's a 1013 or 1015 error message, you can use tinyumbrella to kick the device out of recovery and continue.
 
Dec 9, 2009
26
0
6
#4
Apple is no longer "signing" that firmware, that is why you get the error message. If it's a 1013 or 1015 error message, you can use tinyumbrella to kick the device out of recovery and continue.
But in iTunes shows 4.3.3 is latest version.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#5
Well, have you tried clicking on the check for update button? and is your PC connected to the internet? (that would play a big part in this.)
 

fijiman

Contributor
Silver
Feb 13, 2011
832
64
28
UK
#6
Guys rite now I am in 3.1.2 firmware(3Gs) and I want to upgrade it now. So can you please tell me which firmware as well as i-tunes is safer for jailbreak & unlock. Also I have SHSH blobs from 3.1.2 to 4.2.b3. P.S I don't want tethered jailbreak. BTW I tried restore to 4.3.3 but I am getting "Apple update server error or timeout error".Whats going wrong?. Thanks in advance
You do don't mention using tinyumbrella when upgrading...? as Hawk said

Apple is no longer "signing" that firmware, that is why you get the error message. If it's a 1013 or 1015 error message, you can use tinyumbrella to kick the device out of recovery and continue.
You will need TSS running in tinyumbrella while updating to 4.3.3....the latest version of iTunes is safe to use..