Need Help Restoring iPhone

Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#1
First off, I was told updating iPhone 3G to Version 3.0 while Jailbroken will be OK. It was not ok, and now my iPhone is as far as I know part bricked. Wont turn on.

I plug in the USB cable to iPhone and PC and iTunes says to restore phone. Everytime I try to restore it, I get the error "iPhone could not be restored. Error code (6). Can anybody help me with experience in these issues?

I am running Windows Vista PC. I run iTunes as Admin.
 

BigCiX

Zealot
Gold
Jul 11, 2008
1,445
5
38
Bakersfield, CA
#2
When u plug it up to iTunes hold the home button and don't let go til u see restore iPhone and the actual Apple with the progress bar on the phone. Good luck!
 

alvarezyx

New Member
Jun 18, 2009
7
0
0
#5
I did the same thing - my iPhone was previously J/B - I upgraded to 3.0 and after doing that I started to receive different meesages.....1 was that an iPhone was detected but could not be identified........2 was a message telling me that there was an error. So I'm completely freaked out by now - walked away for a few hours and decided to try the J/B once more. Well, the J/B worked, but for some reason I've lost my cell carrier. I can't make or receive any phone calls and sure enough whenever I go to synch up with iTunes I get the same damn pesky message as before......an iPhone was detected but could not be identified........What should I do guys? I guess are far as the actual sending and receiving phone calls I could probably take it to AT&T tomorrow to see if maybe they can reactivate my sim card. But even so that brings up my 2nd biggest issue and that is the one where for whatever reason I still cannot connect properly to iTunes thereforee I'm not able to add any purchased applications I may have had prior to this J/B.

I really need some serious help and pointers. Please, start shooting some ideas and fixings my way.......
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#6
What I did to fix this was just download the 3.0 Restore Firmware and use that. Press Shift then Restore and choose the 3.0 Firmware.
 

iPhoneMonster

New Member
Bronze
Jan 18, 2009
461
0
0
#7
I guess I was one of the lucky ones. I was jb before and I just upgraded to 3.0 and it worked fine (not jb ofcourse). Only issue I've got is with safari.
 

RedStripe

New Member
Jun 25, 2009
6
0
0
#8
What I did to fix this was just download the 3.0 Restore Firmware and use that. Press Shift then Restore and choose the 3.0 Firmware.
Is the 3.0 Firmware you are talking about the 230MB "iPhone1,2_3.0_7A341_Restore.ipsw" file that was downloaded from Apple when iTunes did the initial upgrade to 3.0 OS?

Also, when you restore to 3.0 firmware, do you lose all your apps you have on your iPhone?
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#9
I need help. I am trying to restore iPhone 3g so i can sell it. I am getting new iPhone tomorrow.

I keep getting error 6. I tried using 3.0 restore, restarting pc, and... using a different port.
 

jhimhope

New Member
Jun 24, 2009
16
0
0
#10
me i got very unlucky when i updated to 3.0, i was stuck on emergency call and my sim can't recognize at all. I restore my iPhone to 3.0 (iPhone1,2_3.0_7A341_Restore.ipsw 230mb) using iTunes 8.2. I got some error but i tried many times and ignore the errors until i succeed. luckily it was restored but my phone can't get any signal sometimes it says "no service" what i deed i install icy and cydia then add rep (repo666.ultrasn0w.com) to cydia. Open cydia and search repo and run. restart my iPhone and gotcha my phone is working fine now.

I read this also to some of the forum sites. Thanks to all of you guyz. cheers! VIVA!
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#11
I tried 3.0 Restore. I cant ignore an error that pops up, just says error 6. Unable to restore iPhone.
 

jhimhope

New Member
Jun 24, 2009
16
0
0
#12
Are you using iTunes 8.2 to do restoring? just try to download again the IPSW maybe it was corrupted while you're downloading. Try to put in DFU mode also.
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#13
I think it is in DFU mode. My iTunes says it found a iPhone in recovery mode and needs to be recovered. Where can I download the 3.0 restore?
 

jhimhope

New Member
Jun 24, 2009
16
0
0
#14

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#15
You need to delete the corrupt .ipsw file first. After deleting it, connect to iTunes and it should redownload it. If that doesn't work try using a different USB port, rebooting the computer, and finally try using a different computer to restore on. If iTunes doesn't automatically download the ipsw file, you can get it here, http://www.iclarified.com/entry/index.php?enid=750 or on one of the above links. Save it to the desktop and then hit shift (command or alt on Mac?) restore.

Here's where the file that needs to be deleted is located. Delete it, redownload and then restore.
On Windows:
Documents and Settings\<User>\Application Data\Apple Computer\iTunes\iPhone Software Updates
On Mac:
~/Library/iTunes/iPhone Software Updates
Here's where the file is located. Delete it and then redownload and restore.
 

RedStripe

New Member
Jun 25, 2009
6
0
0
#16
When you Restore from Backup, what does and does not get restored? I've heard apps don't get restored, is that correct?

I'm not talking about syncing apps. For example, if I've never used iTunes to sync my iPhone since the first day I activated it (except to do a backup), and have since downloaded 100+ apps directly on the iPhone through the App Store app, but never used the "Transfer purchases" to sync my iPhone apps to iTunes, will I lose all my apps when I do a Restore from Backup?
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#17
Ok, so I got this problem fixed. It just took many restarts and retries to restore properly and successfuly.
 

3GiphoneE

Member
Bronze
Nov 27, 2008
30
0
6
#18
my problem is I can't jb my iPhone 3G, with the restore firmware. I've already updated to fm 3.0 with iTunes, that's ok, but i dwld the redsnow and restore file but the error msg is "the path 2_3.0 7A341_restore does not exist or is not a directory".
I've been trying for days but still no luck, i used the dwld from iclarified, and other places but no luck, can any1 help with this? much appreciated.