Need Help Unlocking iPhone

Sep 17, 2009
3
0
0
#1
Hello. I just got an iPhone but it only works for AT&T right now so I need to unlock it.

I upgraded to 3.1 already. I looked up how to unlock it myself which was:

1)download iPhone1,2_3.1_7C144_Custom_Restore.ipsw

2)hold shift and press 'Restore'

3)select the custom firmware and install

This is where I have problems. It takes like ten minutes and then all of a sudden I get a message that says unknown error 1601 or 1604 or something.

Then I press OK and it goes into recovery/dfu mode.

Can somebody please help me and tell me why it's doing this and if I'm doing it wrong? I really wanna use my phone with T-mobile..

Thanks,
Caden Grant
 

one_crazy_dude

Contributor
Bronze
Sep 13, 2009
460
72
28
Toms River New Jersey
#4
Hello. I just got an iPhone but it only works for AT&T right now so I need to unlock it.

I upgraded to 3.1 already. I looked up how to unlock it myself which was:

1)download iPhone1,2_3.1_7C144_Custom_Restore.ipsw

2)hold shift and press 'Restore'

3)select the custom firmware and install

This is where I have problems. It takes like ten minutes and then all of a sudden I get a message that says unknown error 1601 or 1604 or something.

Then I press OK and it goes into recovery/dfu mode.

Can somebody please help me and tell me why it's doing this and if I'm doing it wrong? I really wanna use my phone with T-mobile..

Thanks,
Caden Grant

sorry to here you already up dated to 3.1 first. when you did the update from Apple it changed your base band and now you can not un lock only jailbreak

have a read http://blog.iphone-dev.org/
 

RossMc

Zealot
Gold
Jun 28, 2009
1,124
2
38
28
Newcastle, UK
#5
Yeah as said you can't unlock now and mabey never be able to unlock unless the Dev-Team find a exploit for 3.1 with the baseband already updated or in a future firmware release they find one.
 

one_crazy_dude

Contributor
Bronze
Sep 13, 2009
460
72
28
Toms River New Jersey
#6
how ever if you are having problems just jailbreaking i found this. maybe it will help.this was taken from another forum and dot from me

Just managed to do it….secret id if you upgraded to 3.1 it wont work..you must downgrade back to 3.0 (which is the tricky part), follow http://www.redmondpie.com/downgrade-iphone-3.1-to-3.0.1/
Jail break using redsn0w..then proceed as above..ive done mine and 2 friends phones ..no problems..
Its a bit tricky , but i’m no IT wizard, just read the instructions and go for it….
Peter McG
 

Marianne

Zealot
Moderator
Jul 16, 2007
2,326
29
48
Massachusetts
marianneschultz.com
#7
Depends on which iPhone he has and if he has a PC or Mac. If this is a V1 iPhone and he has a Mac, he can unlock 3.1 with the latest Pwnage tool. It worked flawlessly for my spare V1 iPhone.

EDIT: Apple has a support article on the 1604 error here. At the very least, reboot your computer and check out the section on USB devices.
 

one_crazy_dude

Contributor
Bronze
Sep 13, 2009
460
72
28
Toms River New Jersey
#8
Depends on which iPhone he has and if he has a PC or Mac. If this is a V1 iPhone and he has a Mac, he can unlock 3.1 with the latest Pwnage tool. It worked flawlessly for my spare V1 iPhone.

EDIT: Apple has a support article on the 1604 error here. At the very least, reboot your computer and check out the section on USB devices.
I think there is a bit of confusion.
To unlock is to be able to use any sim from other carriers like t mobile in an AT&T iPhone and to jail break so the phone can accept 3rd party theams and apps. Now if he updated his phone with 3.1 using iTunes and not a jail broken ipsw like he says he did than his base ban has been changed and Cannott go back to older base ban but can go back to older ipsw. If he wants to use another sim from another carrier ultra snow won't work on the new base band.
In the dev team blog(these r the guys who make the software to jailbreak our phones) I posted eairler if read explains the differences between os and baseband.
 

RossMc

Zealot
Gold
Jun 28, 2009
1,124
2
38
28
Newcastle, UK
#9
I think there is a bit of confusion.
To unlock is to be able to use any sim from other carriers like t mobile in an AT&T iPhone and to jail break so the phone can accept 3rd party theams and apps. Now if he updated his phone with 3.1 using iTunes and not a jail broken ipsw like he says he did than his base ban has been changed and Cannott go back to older base ban but can go back to older ipsw. If he wants to use another sim from another carrier ultra snow won't work on the new base band.
In the dev team blog(these r the guys who make the software to jailbreak our phones) I posted eairler if read explains the differences between os and baseband.

The update doesn't affect V1 iPhones though as the baseband will get unlocked using pwnage tool 3.1
 

Marianne

Zealot
Moderator
Jul 16, 2007
2,326
29
48
Massachusetts
marianneschultz.com
#10
I think there is a bit of confusion.
To unlock is to be able to use any sim from other carriers like t mobile in an AT&T iPhone and to jail break so the phone can accept 3rd party theams and apps. Now if he updated his phone with 3.1 using iTunes and not a jail broken ipsw like he says he did than his base ban has been changed and Cannott go back to older base ban but can go back to older ipsw. If he wants to use another sim from another carrier ultra snow won't work on the new base band.
In the dev team blog(these r the guys who make the software to jailbreak our phones) I posted eairler if read explains the differences between os and baseband.
Like I said, it depends on which iPhone he has. From the Dev Team blog:

If you have an original iPhone (1st generation) then 3.1 unlock works with this PwnageTool release.
So, if he has a first-generation iPhone, he CAN unlock 3.1 with the latest Pwnage tool.