NES ver 1.6.2 is Out, but not on Installer

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#1
I don't know why Installer still shows 1.4.0, but whatever. More improvements, this emulator just keeps getting better and better :)

You can download it over at:

http://iPhone.natetrue.com/nesapp

1.5.0 [nervegas] Fixed navbar so buttons update when in landscape mode
Use fclose() instead of close() in LoadROM
Added "Sensory Pad" preference option, good for RPGs I guess
Cleaned up controller selection code and filenames
Enlarged "A & B" hot spot in portrait mode
Tweaked color palette for optimal display on iPhone
Stabilized frame skip, less jerkiness, fewer changes
Added color palette preferences option (old palette = C)
[jordan] Optimized scanline rendering routine
1.6.0 [nervegas] Cleaned up compiler warnings
Fixed sound envelope decay (Punchout, Pinball, Kung Fu)
Fixed volume control restoring music and sounds in many games
More tweaks to Palette A
Added "CPU Clock" advanced option, see README
More work on auto frame-skip
Fixed triangle sound channel
Added bass boost option
1.6.1 [nervegas] Jacked up volume
Compiled with debug on; no debug seems to mess up colors
1.6.2 [nervegas] Addressed crashing issues on orientation change
 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#2
Yeah I seriously don't know what the hell is going on with Installer and NES anymore. I have to manually update every time now. I mean 1.4.0 is what, like a week old now?
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#3
Yeah I don't get it either, but whatevs, where theres a will theres a way.

Have you noticed how much better the music is in this version? Its awesome, its perfect for a high percentage of games now, and has made others sound a lot more tolerable. You know the ones that just made you put it on mute? Well they should sound better now :)

Also, since Installer has been having update frequency issues, I've started to use something else, the PXL installer through Safari. Basically from iBrickr you install the PXL MobileSafari Plugin v1.0.

Once installed you can then just browse to http://pxl.ibrickr.com/ on your iPhone and install from there, or at least thats what it says, lol. I'm about to try it out actually. Their stuff seems to be pretty recent, although their NES is one version behind, 1.6.1, it sure as heck beats 1.4.0...
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#4
I think you are cheating the system by installing stuff like this, and endangering us all.

If Apple thought that NES was possible on your iPhone, without bringing down all of AT&T's west-coast network, they would have given it to you.

I am forced to ask, were you promised NES when you bought your iPhone? Of course not. Yet you have this entitlement attitude that runs contrary to the contract you agreed to when you bought your iPhone.

And don't even think about warranty or technical support. Your warranty is history, after your flagrant illegal behavior.

Can I get a thank you from someone for this post?



--
Mike
 

GP1138

New Member
Bronze
Sep 26, 2007
98
0
0
#5
I want! Maybe I'll actually get the jailer to talk to me on NES Monopoly now! Does PCM sound work now?
 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#6
I think you are cheating the system by installing stuff like this, and endangering us all.

If Apple thought that NES was possible on your iPhone, without bringing down all of AT&T's west-coast network, they would have given it to you.

I am forced to ask, were you promised NES when you bought your iPhone? Of course not. Yet you have this entitlement attitude that runs contrary to the contract you agreed to when you bought your iPhone.

And don't even think about warranty or technical support. Your warranty is history, after your flagrant illegal behavior.

Can I get a thank you from someone for this post?



--
Mike
You support NES and other third party posts in so many of your other posts. Why the sudden change of heart?

Also, NES is not illegal. If it were, Chris wouldn't allow us to discuss it. Wow man, usually I support your opinions 100% but this time around I'm gonna have to say you're a little too over the top.
 

GP1138

New Member
Bronze
Sep 26, 2007
98
0
0
#7
You support NES and other third party posts in so many of your other posts. Why the sudden change of heart?

Also, NES is not illegal. If it were, Chris wouldn't allow us to discuss it. Wow man, usually I support your opinions 100% but this time around I'm gonna have to say you're a little too over the top.
Uh... sarcasm, anyone?
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#10
Oh really, ha. If so, sorry :) I have a hard time telling on the internet (I've never seen Tinman be sarcastic like this before.)
Sorry, wildonrio, I thought the sarcasm would be impossible to miss.

Anyway, suffice to say I foolishly updated to 1.1.1 and was just giving you guys a hard time.


--
Mike
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#13
I think you are cheating the system by installing stuff like this, and endangering us all.

If Apple thought that NES was possible on your iPhone, without bringing down all of AT&T's west-coast network, they would have given it to you.

I am forced to ask, were you promised NES when you bought your iPhone? Of course not. Yet you have this entitlement attitude that runs contrary to the contract you agreed to when you bought your iPhone.

And don't even think about warranty or technical support. Your warranty is history, after your flagrant illegal behavior.

Can I get a thank you from someone for this post?



--
Mike
You are such a hypocrite, dude. Go away. Everything was nice here until you butted in. Who cares what you think? You are so wishy washy about your support for 3rd party apps all over this site.

Can I get a thank you from someone for this post?
 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#15
You are such a hypocrite, dude. Go away. Everything was nice here until you butted in. Who cares what you think? You are so wishy washy about your support for 3rd party apps all over this site.

Can I get a thank you from someone for this post?
He was being sarcastic! Haha, don't worry, I thought he was being serious too. Attention Tinman: I think your post's humor is too hard to read! But now that I know you're kidding, it is pretty funny.
 

domi

New Member
Bronze
Aug 13, 2007
84
0
0
Texas
#17
I think you are cheating the system by installing stuff like this, and endangering us all.

If Apple thought that NES was possible on your iPhone, without bringing down all of AT&T's west-coast network, they would have given it to you.

I am forced to ask, were you promised NES when you bought your iPhone? Of course not. Yet you have this entitlement attitude that runs contrary to the contract you agreed to when you bought your iPhone.

And don't even think about warranty or technical support. Your warranty is history, after your flagrant illegal behavior.

Can I get a thank you from someone for this post?



--
Mike



lmfaorofl! man i must have laughed for at least a minute. thanks tinman, i needed that. hopefully they figure out the 1.1.1 firmware soon so it can be back to the good ol days of 3rd party apps.:cool:
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#18
lmfaorofl! man i must have laughed for at least a minute. thanks tinman, i needed that. hopefully they figure out the 1.1.1 firmware soon so it can be back to the good ol days of 3rd party apps.:cool:
Thanks.

And I should add that I have successfuly downgraded to 1.0.2, so I am back to third-party heaven.

Already have the latest (1.7 as of the moment) NES installed and it looks good.

Also am installing all of my other apps. And after the big scare I am installing just about everything in sight. I don't have a need for those Japanese flash cards, but you better believe I downloaded 'em anyway. Because I can!


--
Mike
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#19
Thanks.

And I should add that I have successfuly downgraded to 1.0.2, so I am back to third-party heaven.

Already have the latest (1.7 as of the moment) NES installed and it looks good.

Also am installing all of my other apps. And after the big scare I am installing just about everything in sight. I don't have a need for those Japanese flash cards, but you better believe I downloaded 'em anyway. Because I can!


--
Mike
Blast from the past:

W?BIC!

Why? Because I Can!

This used to be synonymous with pretty much anything you could do on a pocketPC outside fo PIM, lol.

Anyway thanks for the heads up on 1.7, looks like they have gotten Frameskip working a lot better now. I'm on level 3 of Double Dragon right now, I hope I can continue my Save Point with this new rev. I don't mind working my way back, its just tedious to try and do it with the same stats I had last time T:

Oh yeah, Welcome Back!