New Optimum App not working on jailbroken iPhone 4

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

jakefuzzy

Member
Bronze
Oct 13, 2009
48
4
8
#1
Hopefully I'm posting this in the correct forum. I have a jailbroken iPhone 4 with IOS 4.3.3. I recently downloaded the new Optimum TV App from the app store. When I log in with my optimum ID, it tells me that it has detected that I'm using and unauthorized and modified version of the Apple operating system. It goes on to say that I must update to the current IOS to use this App. I'm definitely not a newbie to the jail break world and have never had this happen with any other app. Is anyone experienced this and is there a work around. Any assistance would be greatly appreciated.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#3
So, the app will not work?

The Skype notification pops up on jailbroken iPhones after you log in for the first time, but it does not disable or modify the app. You just aren't eligible for tech support if you use it on a jailbroken device.
 

jakefuzzy

Member
Bronze
Oct 13, 2009
48
4
8
#5
The thing is, before this newest update to the Optimum App, the App worked well and didn't give me this error. I was able to log in and schedule recordings on my DVR's.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#6
Have you emptied your recycle bin since updating the app and syncing? If not, grab the Optimum.ipa out of the trashcan, delete the app in iTunes, then drag the old file back in and sync.

If you haven't synced the phone since updating the app on the phone (assuming you did sync after you installed the app the first time), the old version is still in iTunes. Just delete the app on your phone and sync.
 

jakefuzzy

Member
Bronze
Oct 13, 2009
48
4
8
#7
Tried that just now. I must have sync'd within the last week and the Optimum.ipa was the current one. I don't have the old version. It was a great thought Europa thanks.
 

Play

New Member
Sep 20, 2011
7
2
3
#8
Hey Jakefuzzy, It's nothing that you did. It was optimum(cablevision) who implemented this last night behind the scenes. The reason I know, is because I went to use the app this morning on my iPad and it said "it appears that this device is running an unauthorized modified version of the Apple operating system. please install the latest Apple operating system software update to use this application". Seeing that, and being pissed off, I called them. A tech told me they made some "security" changes.
What gets me even more mad, is that cablevision is basically telling me (people) what software I'm allowed to use. I feel like Apple should be the ones worrying about jailbroken devices. Skype does a similar check, but your still able to use their app, Cablevision should've done the same. Anyway, Time Warner users had this same issue, and they came up with a patch apropreately named"fucktimewarner" in cydia. Lol! We need a similar patch as well now. Anyway, hopefully someone knows how!
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#9
This is a great reason to get in the habit of not emptying your trashcan until after you've tested recently-updated apps.
 

jakefuzzy

Member
Bronze
Oct 13, 2009
48
4
8
#10
Hey Jakefuzzy, It's nothing that you did. It was optimum(cablevision) who implemented this last night behind the scenes. The reason I know, is because I went to use the app this morning on my iPad and it said "it appears that this device is running an unauthorized modified version of the Apple operating system. please install the latest Apple operating system software update to use this application". Seeing that, and being pissed off, I called them. A tech told me they made some "security" changes.
What gets me even more mad, is that cablevision is basically telling me (people) what software I'm allowed to use. I feel like Apple should be the ones worrying about jailbroken devices. Skype does a similar check, but your still able to use their app, Cablevision should've done the same. Anyway, Time Warner users had this same issue, and they came up with a patch apropreately named"fucktimewarner" in cydia. Lol! We need a similar patch as well now. Anyway, hopefully someone knows how!
Thank you so much. At least I'm not going crazy. I will call and complain tomorrow. We are paying customer. We should be able to use a legal modification of the IOS if we choose and still be able to take advantage of at least one perk Optimum offers.
 

bill old

New Member
Sep 21, 2011
5
0
1
#11
FYI. After updating Optimum and getting same message, I reinstalled old version as per above instructions. I'm unable to log into old version. They're forcing you to update.... Any other solutions out there?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#12
I guess the server detects that it's jailbroken, even when using old versions of the app, and disables logging in until the jailbreak is removed. Lame.

Sorry, I can't think of anything else that would work.
 

jakefuzzy

Member
Bronze
Oct 13, 2009
48
4
8
#14
I just spoke to 2 separate supervisors at Optimum. They were useless. I'm drafting an editorial to New Jersey's 2 major newspapers, Star Ledger and the Asbury Park Press about this. I know the columnist in both. Hopefully we can shame them into doing something.
 
Sep 21, 2011
10
3
3
New York, New York
#15
Thry this solution and let me know if it's working for you:

Install iFile. (in cydia)
Then open up iFile, goto this path location:
/System/Library/CoreServices/SystemVersion.plist

Edit the SystemVersion.plist using iFile. Change Product Build Version to "8L1" and the Product Version to "4.3.5" (no quotes) as seen below.

<key>ProductBuildVersion</key>
<string>8L1</string>
<key>ProductVersion</key>
<string>4.3.5</string>

Save and reboot phone!
 

Play

New Member
Sep 20, 2011
7
2
3
#16
Hey Alexsandr, I just tried what you suggested and it didn't work. I got the same error, "it appears that this device is running an unauthorized modified version of the Apple operating system. please install the latest Apple operating system software update to use this application". I know they are detecting a " modified" version from their end. I don't know how, but they are. Thanks though for your help.