No Modem Firmware?

kclust

New Member
Sep 28, 2008
6
0
0
#1
I have a 3G, 8GB iPhone. I recently got a 16GB version. The 8GB was jailbroken (2.2.1) and I tried to completely erase and restore as a new phone using iTunes. iTunes returned an error of 1002, so I tried to rejailbreak the phone, which appeared to be successful. However when I reboot the phone and insert the working ATT sim, it still says "searching" in the signal area in the upper left corner of the screen. Upon checking the Settings|General|About, the phone shows 2.2.1(5H11) in the Version, but shows nothing in the Modem Firmware field. I'm sure it should say 2.30.03, but there's nothing there.

I've tried restoring from iTunes about 5 times and even tried jailbreaking three more, but nothing seems to work. Can someone give me an idea of what else to try?
 

Adam1389

Member
Silver
Nov 20, 2008
588
1
18
Ilwaco, WA
#2
Are you just plugging it in and doing a restore in iTunes? Might try DFU mode on the phone and see if that does it.
 

kclust

New Member
Sep 28, 2008
6
0
0
#3
I tried DFU mode (I'm using Vista) and it still restored the software before the firmware. I thought I read somewhere that if restoring from DFU mode it updated only the firmware. Anyway, it did a complete restore and at the end I still got error 1002. This takes about 45 minutes each time, by the way. What else can I try?
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#4
Really should have nothing to do with it...but are you trying to restore from back up, or set up as a new phone? Personally I would download the 2.2.1 firmware and use the shift (option on mac) + click on update and use the downloaded firmware and set up as a new phone.

You can download the firmware here http://thebigboss.org/guides/iphone-firmware-files/
 

kclust

New Member
Sep 28, 2008
6
0
0
#5
I tried downloading the firmware again and reinstalling through iTunes in DFU mode. Still no luck. Anything the Apple store can do that I can't?
 

binz

New Member
Apr 6, 2009
13
0
0
#6
what does DFU mean?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#7
To my knowledge, unless you are unlocked, you cannot take the SIM from the working phone and put it in the other. If both accounts are active, then you have a problem, but if you switched service from the 8GB to the 16GB, then the 8GB is technically "off line".
If it's a bigger problem, then you would see WiFi and BT grayed out as well. That's definitely a modem firmware/com card prolem.
 

teamiphone

New Member
May 4, 2009
7
0
0
#8
I attempted to jailbreak my iPhone 3g which seemed to work for about 2 weeks then rebooted itself and have had no service since. I have done multiple restores both with and without DFU mode. I used QuickPwn 2.2.5 and have jailbroke my phone again back to where I have my icons but here is where Im stuck:

I have no service bars (Im a ligit ATT customer)
Wi-Fi: No Wi-Fi (greyed out)
Version: 2.0 (5A347)
Wi-Fi Address: N/A
Bluetooth: 00:00:00:00:00:00
IMEI: blank
ICCID: blank
Modem Firmware: blank

It seems like I need to flash the modem firmware, is this correct? How do I do that? Im using Windows Vista or XP. ANy help is greatly appreciated.

Thanks