No Signal, after unlock

Oct 28, 2007
24
0
0
#1
I got an iPhone, that ive unlocked recently, and for some reason i have an annoying problem.

I have no signal.

I know everything is right, its activated and all, but nothing.

Ive tried IPE Tools, Lock Down Patch, and its done nothing.

Thank for the replies!
 

07fa4drSi

New Member
Bronze
Feb 11, 2008
30
0
0
#2
I got an iPhone, that ive unlocked recently, and for some reason i have an annoying problem.

I have no signal.

I know everything is right, its activated and all, but nothing.

Ive tried IPE Tools, Lock Down Patch, and its done nothing.

Thank for the replies!


Pretty sure you need to go to settings on the iPhone go to reset section and reset your network settings i had a similar problem and this fixed everything right up
 

Uncle Luke

New Member
Aug 6, 2009
1
0
0
30
#4
I had the same problem with my 3gs. I found that if you install BossPrefs from Cydia, then turn everything off through BossPrefs and reboot device from BossPrefs (Reboot from BossPrefs very important) works. After device reboots, go to settings and turn airplane mode on then off. Give phone about 2 minutes or less and your signal should be found.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#5
What carrier are you on now you've unlocked your device?

If it's T-mobile, then i suggest you turn your 3G off.

Your signal, will come back once you've done this.
 

mtwhite

New Member
Sep 5, 2009
2
0
0
#6
Tried BossPrefs - no luck

Any other options out there? I've tried the BossPrefs steps, turned off 3G, edited both cellular and data network settings. Still no signal. I'm with T-Mobile US.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#7
Is there any possible way that the IMEI could be blocked?

It's either that, or a defective phone/sim
 

mtwhite

New Member
Sep 5, 2009
2
0
0
#8
I don't think it's locked. I have brief moments of good signal as I drive around. I went to t-mobile and got a new SIM card to see if mine was so old (prob 2.5 years) that it may need upgrading. Really no difference.

I've used a Palm Treo with the SIM and it gets 5 bars almost all of the time. I've tried just about all I know to do, guess it's time to sell it and call it a day.
 

nathanca

New Member
Sep 20, 2009
1
0
0
#9
I had the same problem. After unlocked a 3GS/16GB with version 3.0.1, there was no net network signal. I reset the network, turned off 3G, tried with different SIMs. Sometimes where was a little signal, then it went away to No Service. I opened up the iPhone, sure enough the signal cable (number 7) was loose. I plugged it back nice and tight, then it worked like a charm.
 
Oct 18, 2009
1
0
0
#10
Hey Uncle Luke, you saved my iPhone! Thank you so much for this suggestion, It totally works for me!
 

prguy

New Member
Apr 2, 2010
3
0
0
#11
I had the same problem. After unlocked a 3GS/16GB with version 3.0.1, there was no net network signal. I reset the network, turned off 3G, tried with different SIMs. Sometimes where was a little signal, then it went away to No Service. I opened up the iPhone, sure enough the signal cable (number 7) was loose. I plugged it back nice and tight, then it worked like a charm.

wheres cable number 7?
 

lgp927

Member
Bronze
Nov 23, 2009
96
0
16
#12
I have tried this on my 3g w 3.1.2 and it still don't have any signal


I had the same problem with my 3gs. I found that if you install BossPrefs from Cydia, then turn everything off through BossPrefs and reboot device from BossPrefs (Reboot from BossPrefs very important) works. After device reboots, go to settings and turn airplane mode on then off. Give phone about 2 minutes or less and your signal should be found.
 

toygixxer750

Member
Bronze
Dec 22, 2007
36
0
6
#13
wheres cable number 7?
FINALLY! Cable 7 is the antenna cable inside the iPhone once you opened up your phone. I've been having problem with my iPhone signal & been searching for a solution. Tried JB & unlock over and over, but finally read about the "cable 7" in this thread. Now it works perfect.
 
Oct 22, 2010
1
0
0
#14
help

i got my iPhone unlocked so i culd put my orange sim card into it, after getting it back when i put my orange sim in its comes up orange but i have no signal, i have tried resetting the network settings but could do with help!
 
Sep 6, 2010
2,485
22
48
#15
I had this same problem the other night, after unlocking my 3GS. It kept saying no signal. I was finally able to get a signal, after putting the 3GS in Airplane mode for a few seconds.