"No SIM card installed"

wennos

New Member
Jul 19, 2009
1
0
0
#1
Hi, my apologies if anyone has already asked this......

For no reason my iPhone came up with this message, and I do have a sim card installed which has always been fine :)

I have looked all over the net for answers and have tried turning it on and off, resetting general settings and network settings, switching to and from airplane mode, powering off, syncing. I also tried the SIM card in another phone and it works, so it must be my phone.

Anyone have any ideas?

Many thanks!
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#2
When you say it's coming up with a warning, does this error not correct itself?

does your phone not work at all?

If your phone ceases to work even after trying your SIM in another phone (so you can rule out SIM problems) i'm pretty certain Apple will give you a swap :)
 

Saurabh

New Member
Bronze
Sep 5, 2007
152
0
0
VA
#3
Go to the Apple store if your still in warranty and they will replace your phone. in my case my sim was the issue. It was all bent up and what not. ATT will give you a brandnew sim card free according to an Apple store employee.
 
Jun 30, 2009
231
0
0
#5
Have you tried rebooting? I think yes. Then Apple store is the last destination for you. Go there and try to replace it with a new one if possible. Best of luck.
 

JimmyZ

New Member
Sep 8, 2009
1
0
0
#6
Same thing, only right after installing 3.0.1

This happened to me right after installing 3.0.1

I have no idea why...

But a cold boot fixes it, sometimes, for a while... an hour or two, but then it happens again.

Looks like I'm heading to the Apple store tomorrow.