No SIM card/ invalid SIM card

Discussion in 'iPhone 4S' started by Johnlennon78, Sep 19, 2012.

  1. Johnlennon78

    Johnlennon78 Member
    Bronze

    Joined:
    Dec 25, 2011
    Likes Received:
    3
    Hello guys,

    I have been experimenting some weird stuff on my iPhone 4s since yesterday. I will get the message invalid sim card on my iPhone. I turned it off, started it again and it was fine. I could get and make phone calls , send and receive SMS. After ten min or so new message appeared which says no sim card. Tried to reboot 3x, with no result. Left iPhone off for about 15 min and turned it on, now it works. Left it on for the whole day no prob. This scares me as I have never dropped the phone. I have ios 5.1.1 which was the latest as of yesterday. Has anyone of you experienced the same thing? Should I go back to the store and returned it since I still have a warranty on it until novmeber? Thank you for your suggestions!
     
  2. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,442
    Yes, I experienced this a few times on my iPhone 4. Removing the SIM and putting it back in should fix the problem.
     
  3. Johnlennon78

    Johnlennon78 Member
    Bronze

    Joined:
    Dec 25, 2011
    Likes Received:
    3
    yes! I forgot to mention I did remove the sim card a few times the second time it happened to me.
     
  4. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,442
    You still have a couple months of warranty if you want to see if it keeps doing it. I never replaced mine because reseating the SIM always worked. But if it does continue to do this, I recommend getting a replacement SIM card at AT&T and restoring to factory settings before replacing the phone.
     

Share This Page