no WiFi, need to jailbreak iOS 4.2.1 iPhone 3G

SadPanda

New Member
Dec 2, 2011
1
0
1
#1
Hi guys,
I am really having a tough time and I am praying that somebody will have a solution for me. I have an iPhone 3G that was on iOS3 (don’t remember exact number but I know I used Blackra1n). I upgraded it to iOS 4 and it got really slow and my wifi stopped working. I upgraded again and am currently on iOS 4.2.1. My Baseband is 05.15.04. Wifi still doesn’t work.
How can I jailbreak this phone and get the wifi working again? Keep in mind I do not have wifi or any sort of cellular data (I was using a non-ATT sim card).
Thank you in advance for helping me and have a merry Christmas!
 

iAnnie

Member
Bronze
Dec 4, 2011
35
0
6
#3
Downgrade it to 3.1.3. The iPhone 3G will be most optimal there. Jb with Redsn0w 0.9.4 (use a 3.1.2 ipsw with RS but restore to 3.1.3. Set the phone up as new after restoring, if it isn't a hardware failure, doing this should fix your wifi.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#4
No need to downgrade, several tools available to jailbreak the 3G running 4.2.1:

Redsnow
Snowbreeze
Pawnagetool
Greenpoison
 

iAnnie

Member
Bronze
Dec 4, 2011
35
0
6
#5
It's not a question of need. The device runs better on 3.1.3. The OP didn't like the way iOS 4 slows the device down.
 

iAnnie

Member
Bronze
Dec 4, 2011
35
0
6
#6
And Greenpois0n doesn't work on iPhone 3G.
 

iAnnie

Member
Bronze
Dec 4, 2011
35
0
6
#8
Disagree all you want. The OP can choose either route, they're both on the table. Sometimes it's better to tell people the device can have better performance on a different version than to just say here's what you wanted.

http://www.iphonehacks.com/2011/02/greenpois0n-untethered-jailbreak-for-ios-4-2-1-released.html

If you scroll down and read the updates, GP for Mac will support the 3G. But then an update excludes it. For windows, it wasn't included at all. That and how many iPhone 3G have you jailbroken on 4.2.1 with GP? How many have you seen succeeded? I've seen dozens fail. Don't think just bc I'm a new member I don't know what I'm talking about.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#10
ha - don't think that because ive been around a while i presume I know everything. On the other hand, don't think I know nothing - I have jailbroken mine and my partners 3G running that firmware - and I have been jailbreaking iPhones since the original was released - I know what im talking about too.
 

iAnnie

Member
Bronze
Dec 4, 2011
35
0
6
#11
If you say so. It doesn't work on an iPhone 3G on 4.2.1. Plain and simple. Unless sources lie.