Not Receiving SMS Or MMS Messages Only iMessages

ITS ME DAVID

Evangelist
Gold
Jul 8, 2010
1,358
112
63
L.A C.A
#1
as the title says I have iMessage on and SMS on but can't send or receive regular or mms messages only iMessages go through. I already reset network settings turned on ad off iMessage I even did a hard reset still nothing.
 
Dec 15, 2008
5,386
340
83
27
Pensacola, FL
#2
I hope this article help you out. The only issues I've had that are related to your problem is when I am not in an area that can send or receive text messages (no service). Unfortunately, it's quite early to see any discussions about issues with the iPhone 5 as far as this goes. Also, Apple does not have help online yet for the iPhone 5 issues.

http://support.apple.com/kb/TS2755
 

parmacrafter

Member
Bronze
Mar 10, 2012
31
9
8
#3
I had same issue when I first got and activated my phone. After several frustrating hours I found out that my carrier (Sprint) had not properly activated my phone. If you haven't already, you should call your carrier and ask them to re-provision your phone.
 

ITS ME DAVID

Evangelist
Gold
Jul 8, 2010
1,358
112
63
L.A C.A
#4
Well my other line is a 4s had since launch is having the same problem can't send or receive text or mms since i uodated to ios6 I called att they said there is something holding the messages in there system it shows messages being held up but they don't know why so they put a ticket for technical help and someone should be contacting me by the 27th this sucks but att did give me some discount incentives.
 

FFAP1234

Member
Bronze
Jun 12, 2010
429
12
18
#6
I also had the same problem and it was solved when I removed the SIM Card from the previous phone. In other words I upgraded the iPhone 5 from the iPhone 4S, as soon as I removed the SIM Card from the 4S the problem went away.
 

FFAP1234

Member
Bronze
Jun 12, 2010
429
12
18
#10
I appreciate the input but this problem is happening on my other line which has a 4s on ios6 also.
NP, I was very frustrated because of the same situation and magically, after I resorted my iPhone 4S from my last backup and then removed the SIM Card the problem was solved : )
 

parmacrafter

Member
Bronze
Mar 10, 2012
31
9
8
#11
By default IOS 6 Turns on iMessage but turns off SMS and MMS. Have you checked the settings for messages to make sure that all 3 items are turned on?
 

FuelieNova

Contributor
Silver
Aug 3, 2008
636
33
28
#13
Who is your carrier? I had the exact same problem on my 4s and new 5 AFTER receiving and activating my 5. I called ATT, they had me text 151 (i think) as a test. It didn't work. They worked with me on the line for about 15 minutes and then did something on their end and everything started working.
Tom
 

ITS ME DAVID

Evangelist
Gold
Jul 8, 2010
1,358
112
63
L.A C.A
#14
yes I texted that number but it goes through to att but anyone else it doesn't they tried everything and right now I got off with Apple and he said he's received calls and at the moment there isn't a fix but he sent a note to the engineers.
 

ITS ME DAVID

Evangelist
Gold
Jul 8, 2010
1,358
112
63
L.A C.A
#16
Well att figured it out it seems that when I called last week about having no lte on Friday what a att rep told me lte was in my area they offered me a $20 discount on my messaging plan so I accepted but the att rep put it for sept 27 when he did that I guess it removed messaging then was gonna auto add on sept 27 so basically even when it shows I has messaging it wasn't enabled.
 

nick v

New Member
Oct 20, 2012
1
0
1
Port Saint Lucie, Florida
#19
100% fix:
it takes a little iPhone know how, but works 100%. When the phone comes from one carrier to another the c0m Apple mms_override.plist file isn't changed when restored from backup, even if you reset the network settings, so what you need to do is edit this file.
in iTunes make a backup of your phone
Download ibackupbot to edit your back up
find the file com Apple mms_override.plist
edit this file to look like this:
(it won't let me put in the first two lines of code because there is a web link in them, so leave the first two lines that are in the file)

<plist version="1.0">
<dict>
<key>MMS</key>
<dict/>
</dict>
</plist>

click the little disk icon to save your changes, and then quit ibackupbot
open iTunes, and restore from your backup
TA FREAKIN DA!
 

iq201

New Member
Oct 21, 2012
1
0
1
#20
100% fix:
it takes a little iPhone know how, but works 100%. When the phone comes from one carrier to another the c0m Apple mms_override.plist file isn't changed when restored from backup, even if you reset the network settings, so what you need to do is edit this file.
in iTunes make a backup of your phone
Download ibackupbot to edit your back up
find the file com Apple mms_override.plist
edit this file to look like this:
(it won't let me put in the first two lines of code because there is a web link in them, so leave the first two lines that are in the file)

<plist version="1.0">
<dict>
<key>MMS</key>
<dict/>
</dict>
</plist>

click the little disk icon to save your changes, and then quit ibackupbot
open iTunes, and restore from your backup
TA FREAKIN DA!
I downloaded ibackupbot. When I tried to edit that file, the software said I have to purchase a full version of ibackupbot, which costs $35. Help me out here...