Official 3.0 Beta bug list

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#1
Ok, let's get all reports in here. Please, only apps and processes that are not currently working. What I've found so far:

1. Rooms is fine if you restore from backup with your server info intact. The screen where you enter server info, however, has a bug where the keyboard won't stay up, rendering it unusable.

2. Some things require a hard reset to work the first time (like shake to shuffle on the iPod)

3. MMS, of course doesn't work on my V1, and apparently isn't working for anyone on 3G either.

Updates to come, of course...
 
#2
You Tube doe NOT work if you restore from a backup after installing v3.o, at least for me and some others.

Trying to reply to a PM on EIC in Safari isn't possible. The C&P seems to be preventing the cursor from being positioned anywhere in the text and the page can't be scrolled. Probably not limited to EIC, bt to many web messaging pages.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#3
I restored as new and Youtube is working on mine.
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#4
I suspect to get MMS working on the 3G (and maybe even v1) you would need to call ATT and change from a iPhone texting plan to a normal one. This is what people had to do to get swirly MMS to work if I remember correctly.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#5
I don't think any known trick that has formerly worked to get MMS is now working, however.
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#8
I had a couple glitches in safari where the text in the address bar and search bar was white (instead of black) and I couldn't see it.
Also youtube doesn't work for me either. I restored from a backup.
Here are a couple screenshots.

 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#9
Sometimes the messages app slows WAY down, so that all my letters type in one per like 5 seconds.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#11
"Voice Keyboard" doesn't appear to work. It takes forever to load, and I can't get a sound out of it.

I'm really amazed how nearly every app works flawlessly.
 
Jun 19, 2007
33,493
4,550
113
Upper Marlboro, MD
#12
I noticed when setting up email accounts that the backspace key would sometimes hang for about 20 or so seconds before starting to move again.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#13
The glitchiest things I've noticed so far have to do with keyboard popups. Most work eventually with a little fidgeting, but it totally thwarts my attempts to setup an IRC server in Rooms.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#15
The biggest lag I'm noticing is waiting for the keyboard to pop up in certain apps (Notes, mostly). Everything else is quite zippy.

Anyone else noticing Google mobile app is a LOT faster to load/accept a voice command?
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#16
JJ reminded me of another... no cursor in text entry using Safari, and passwords can appear quite messed up while typing them in.
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#17
Aw this sucks, the more I use 3.0 the more lag I get. Shazam doesn't work either...
 

Picazzo

Zealot
Gold
Jan 21, 2008
2,808
15
38
Copenhagen, Denmark
#18
I sitting here and are almost ready for testing the 3.0 beta. But I remember these terrible lags from the jailbreak - is it the same her guy's?
 
#20
I have posted a message on the Apple Dev Forum askiing about MMS:

MMS Authorization with AT&T
Mar 19, 2009 5:38 AM
Although my app doesn't make use of MMS I have found that AT&T will not allow MMS messages. Is there a method in place to authorize AT&T to permit MMS on devices authorized for testing? I contacted them and got the standard answer that it is not supported on the iPhone and cannot be activated, even for v3.0 test devices.
And the unofficial/official reply so far is:

In response to up10ad on Mar 19, 2009 5:50 AM

After going through a dozen att reps both in the corp store and over the phone I finally reached someone who knew about the situation and was just there answering calls on this topic (had to ask for a supervisor and they transferred me to "tech department rep that knows situation").

Basically, Apple didn't inform ATT about this new firmware beta and it took them by complete surprise. There system is setup in such a way they it has a front and back end for MMS. It is possable for one of the reps on the phone to unblock MMS for your account on the front end, but then the back end auto detects your IMEI and changes it back.

So this is going to have to be some sort of system wide change for them to lift the MMS restriction on iPhone accounts. The Tech rep kept saying that they should have it ready by the summer. I told her that Apple plans on making the firmware live for all customers by summer and I would hope that they have it running before that.

We are probably going to have to wait a while :(
up10ad

In response to MikesTooLz on Mar 19, 2009 5:53 AM

Thanks, I have heard about that front-end/back-end too. Hopefully Apple will get with them and iron it out well before 'summer'.
I'll let you know if I get any 'official' responses from Apple staff, the guy that responded isn't a heavy hitter.