OMG WIFI still doesn't work

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

RRGOO7

New Member
Jul 14, 2007
1
0
0
#1
Ok guys. I think ive tried everything. For some reason my wifi does not work on the wireless in my house. It work at all my friends house except mine!

I have reset my router and my iPhone and still have had NO luck. I was reading in the other reading about typing in some numbers but i couldnt understand where i needed to go on the phone.

My router is Linksys WRT54G and my network has no password.

PLEASE HELP
 

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
#2
You may need to manually add your DNS server addresses into your iPhone Wi-Fi set-up.

You can check your DNS setting by looking at your linksys Router's config pages

simply look at http: // 192.168.1.1 (Linksys Router Homepage - remove spaces) on your home network, then look at the STATUS page to see the current DNS IP addresses listed.

Enter these into your iPhone wi-fi set-up
 
Last edited by a moderator:

nutdhanai

New Member
Jul 15, 2007
1
0
0
#3
Have you tried this? (mind you, i am using a activation-hacked iPhone, with att sim removed)

On your iPhone, go to -> settings -> general -> reset -> reset network settings

after that turn your wifi on/off then it should connect as usual..

hope this helps
 

Yantez

New Member
Jul 15, 2007
1
0
0
#4
Same Problem

Have you tried this? (mind you, i am using a activation-hacked iPhone, with att sim removed)

On your iPhone, go to -> settings -> general -> reset -> reset network settings

after that turn your wifi on/off then it should connect as usual..

hope this helps
I had to update the firmware on my router - then it connected with no problems.
 

burniksapwet

Member
Silver
Jul 5, 2007
553
0
16
#5
I had this problem before. Call your internet provider and ask for the main DNS number. It is not the 192…. number.

  • Go to your wifi settings and under security make sure that you choose WEP hex or ASCII
  • Type in your password
  • Select the blue arrow next to the network you are connected to.
  • Select DNS.
  • Change the IP Address to what ever number your internet provider gave you. (I might be a 208……number)
Please let us know if this works.
 

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
#6
I had this problem before. Call your internet provider and ask for the main DNS number. It is not the 192…. number.

  • Go to your wifi settings and under security make sure that you choose WEP hex or ASCII
  • Type in your password
  • Select the blue arrow next to the network you are connected to.
  • Select DNS.
  • Change the IP Address to what ever number your internet provider gave you. (I might be a 208……number)
Please let us know if this works.
he can use the 192.168.1.1 address from a web browser to look at his Router, and get the DNS from the router itself.

You can then key those DNS numbers into the iPhone as you suggested.
 

burniksapwet

Member
Silver
Jul 5, 2007
553
0
16
#7
he can use the 192.168.1.1 address from a web browser to look at his Router, and get the DNS from the router itself.

You can then key those DNS numbers into the iPhone as you suggested.
But doesn’t the router give him the 192 no? I really don’t know a whole lot about this but when I entered the one I found on my router it didn’t work. I had to call my internet provider and ask them the number and the number they gave me was nowhere to be found in any of my settings.
 

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
#8
But doesn’t the router give him the 192 no? I really don’t know a whole lot about this but when I entered the one I found on my router it didn’t work. I had to call my internet provider and ask them the number and the number they gave me was nowhere to be found in any of my settings.
The Linksys router gives you a number of 'web pages' when you type it's IP address into your web browser. (192.168.1.1)

These allow you to set up your router using just a browser - and also see the settings that your ISP has given to the router.



When you look at the STATUS tab, you should see the IP addresses that your ISP has provided for DNS - these are ringed in red here - you can then type these IP addresses into your iPhone
 

burniksapwet

Member
Silver
Jul 5, 2007
553
0
16
#9
The Linksys router gives you a number of 'web pages' when you type it's IP address into your web browser. (192.168.1.1)

These allow you to set up your router using just a browser - and also see the settings that your ISP has given to the router.



When you look at the STATUS tab, you should see the IP addresses that your ISP has provided for DNS - these are ringed in red here - you can then type these IP addresses into your iPhone
I guess its different with the type of router you have.:) Mine doesn't show it like that. I forget what type of router I have.
 

Xaero

New Member
Dec 31, 2007
1
0
0
#11
Wi-Fi on the iPhone gave me the most pain in the world =) after trying EVERYTHING and EVERY solution posted online, i had no success. The damn thing was just NOT connecting. However, my dad who is a computer developer was able to figure it out after hours of searching.

The problem is that iPhone wi-fi does not support G connection from your router, its too damn fast for it. So what you have to do, is setup your router to not only support G connection, but also the slower type of connection, i think its called B or something

Here what you have to do:

Go to your router setup by typing in your own ip into the search window on the browser.

if you do not know your ip, click start, run, cmd, ipconfig; usually it is 192.168.1.1

If it was not setup before, leave the logic name blank, and for password type admin.

Finally, change the settings inside from G only to support the slower type. I am not sure where you do it in the settings, so just dig around or look it up on google.

After that, you're done! Sorry if my instructions arent completely clear, but its the only thing that worked for. GOOD LUCK!
 

KNK

New Member
Jul 22, 2007
2,391
1
0
Stevenson Ranch
#12
Wi-Fi on the iPhone gave me the most pain in the world =) after trying EVERYTHING and EVERY solution posted online, i had no success. The damn thing was just NOT connecting. However, my dad who is a computer developer was able to figure it out after hours of searching.

The problem is that iPhone wi-fi does not support G connection from your router, its too damn fast for it. So what you have to do, is setup your router to not only support G connection, but also the slower type of connection, i think its called B or something

Here what you have to do:

Go to your router setup by typing in your own ip into the search window on the browser.

if you do not know your ip, click start, run, cmd, ipconfig; usually it is 192.168.1.1

If it was not setup before, leave the logic name blank, and for password type admin.

Finally, change the settings inside from G only to support the slower type. I am not sure where you do it in the settings, so just dig around or look it up on google.

After that, you're done! Sorry if my instructions arent completely clear, but its the only thing that worked for. GOOD LUCK!

Good post. The iPhone is setup for B & G, with G being faster. I however am on the Netgear Gigabit N and mine works spectacular.