Password Capitalization bug in v 1.1.1 iPhone

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

DisneyEcho

New Member
Bronze
Jul 14, 2007
54
0
0
disneyecho.emuck.com
#1
I noticed that this bug came in with version 1.1.1 of iPhone today:

When logging into any website forum, such as this one, now the capitalization key on the iPhone acts weird when putting in your password.

When tapping the capitalization button (and not a double-tap) it now remains on and makes not just the first letter you type after that a capital letter, but all of them -- until you manually turn off the capitalization. It is now acting as if you double-clicked it, but does not turn blue (assuming you have enabled this in your settings).

This messed me up many times today before I saw/realized that the capitalization button was not turning off automatically after a letter was pressed after turning the button on, as it used to do (and probably is supposed to do).

I don't think this is a new "feature" but a new bug, and I point it out to all reading this who are wondering why they are all of a sudden having trouble logging into this forum (and all similar forums: it is happening on my Disney Echo forum as well).

I've reported this bug to Apple tonight, but this is a heads-up to all until they put out another revision, fixing this bug.

 

Learned

New Member
Sep 28, 2007
1
0
0
#3
Thank you!

I was going nuts last night trying to log into our corporate webmail. Thanks for catching that.

I noticed that this bug came in with version 1.1.1 of iPhone today:

When logging into any website forum, such as this one, now the capitalization key on the iPhone acts weird when putting in your password.

When tapping the capitalization button (and not a double-tap) it now remains on and makes not just the first letter you type after that a capital letter, but all of them -- until you manually turn off the capitalization. It is now acting as if you double-clicked it, but does not turn blue (assuming you have enabled this in your settings).

This messed me up many times today before I saw/realized that the capitalization button was not turning off automatically after a letter was pressed after turning the button on, as it used to do (and probably is supposed to do).

I don't think this is a new "feature" but a new bug, and I point it out to all reading this who are wondering why they are all of a sudden having trouble logging into this forum (and all similar forums: it is happening on my Disney Echo forum as well).

I've reported this bug to Apple tonight, but this is a heads-up to all until they put out another revision, fixing this bug.

 

DisneyEcho

New Member
Bronze
Jul 14, 2007
54
0
0
disneyecho.emuck.com
#4
So, more than just web forum logins affected... Wow!

I was going nuts last night trying to log into our corporate webmail. Thanks for catching that.
My pleasure! I was going nuts myself yesterday on web forums until I noticed that the capitalization button wasn't turning off by itself after the next letter keypress as it had automatically since the iPhone first came out.

I wasn't aware until you replied, though, that it was affecting more than just logging into forums, but also to things like corporate webmail.

I wonder if this bug is happening in all cases where a password is needed to log in?

I don't know how the capitalization bug happens just on password fields and not when generally typing things in anywhere else, including writing an email message, in notes, or even in the log-in field when logging in anywhere.

Perhaps Apple didn't catch this bug in 1.1.1 because they used all lowercase letters in passwords when they testing logging in? I wonder how this got past them.

 

DisneyEcho

New Member
Bronze
Jul 14, 2007
54
0
0
disneyecho.emuck.com
#6
Bug fixed in version 1.1.2

I noticed that this bug came in with version 1.1.1 of iPhone today:

When logging into any website forum, such as this one, now the capitalization key on the iPhone acts weird when putting in your password.

When tapping the capitalization button (and not a double-tap) it now remains on and makes not just the first letter you type after that a capital letter, but all of them -- until you manually turn off the capitalization. It is now acting as if you double-clicked it, but does not turn blue (assuming you have enabled this in your settings).

This messed me up many times today before I saw/realized that the capitalization button was not turning off automatically after a letter was pressed after turning the button on, as it used to do (and probably is supposed to do).

I don't think this is a new "feature" but a new bug, and I point it out to all reading this who are wondering why they are all of a sudden having trouble logging into this forum (and all similar forums: it is happening on my Disney Echo forum as well).

I've reported this bug to Apple tonight, but this is a heads-up to all until they put out another revision, fixing this bug.

This bug has now been fixed in iPhone version 1.1.2

It was my pleasure to help!
 

seb481

New Member
Silver
Aug 3, 2007
774
1
0
San Diego
#7
couldn't loggon to my neighbors wifi anymore until i figured out the was a CAP problem. it took me a few minutes to figure it out...