Phone icon MIA (at times)

djwindsor

Contributor
Silver
Jul 7, 2009
755
44
28
Neponsit, NY
#1
I usually try to figure things out for myself and this forum is a fabulous resource. I've finally upgraded to 5.0.1 and used redsn0w to JB. I've had no issues to speak of and I find this JB to be more stable than the one I had on 4.3.3. It also can be due to the fact that when I restored with pkgbackup (great app) and only chose the bare minimum of tweaks to minimize conflicts. I'm using infinidock which MAY be the cause of my problems. Every so often the PHONE icon will disappear from my dock. I relocated it on the dock to a position other than the first one and it still at times disappears. All I have to do to make it reappear is put the icons in wiggle mode (forgot the proper terminology but you know what I mean :). Anyone have any clues? Can it be that infinidock is not playing nice with 5.0.1? Any ideas would be appreciated. TIA
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,895
2,059
113
Florida
#2
Not sure on that, but mine will occasionally go white and have to respring to get it back. I used absinthe for my JB. It always seems to happen after a visit to cydia, especially if I update or download something.
Pita, but not too bad I guess.
 
Dec 10, 2009
2,589
1,337
113
52
Clarksburg, WV
#3
Only way to tell for sure is to remove tweaks until problem goes away.
Likely a negative interaction between 2 similar Cydia items.

I know I'd reappear if someone put me in wiggle mode....
 

gotzaiPhone

Zealot
Gold
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#4
Are you using springtomize? My icon disappearing and going all white issues are solved when I go into springtomize and hit the reload button.
 

flightmedic

Member
Bronze
Jun 21, 2009
397
23
18
Wichita Falls, Texas
#5
I've had that issue also, mainly after a reboot or respring. The SB will load without the phone app there. I respring again and all is good. I JB with Absinthe. Only happened a few times so far. Hope this helps.
 

djwindsor

Contributor
Silver
Jul 7, 2009
755
44
28
Neponsit, NY
#6
Thanks for all the replies. This issue is still occurring but it only happens when the phone randomly resprings. It is hard to narrow down the culprit because I'd have to turn a tweak off and then wait for a possible respring to occur which could be hours or days. The only way to tell if my phone has resprung is when I notice the invisible phone icon. Regardless, I'm gonna deal with it as I don't have the patience to turn off and on my tweaks. I have minimized my tweaks with this JB because I had way too many on 4.3.3. As you all probably realize, the more tweaks you have, the likelihood of negative interaction is greater. In addition, I've noticed the system is slower if you have too many tweaks installed. Overall, I still am pleased with the stability of this JB.
 

Troubleina

Member
Bronze
Mar 5, 2009
118
2
18
Suburban Washington DC
#7
boy am i glad i saw this! the wiggle mode thing saved me! seriously, i was going nuts, rebooting, re sprining etc, to find the phone icon. sometimes it would show up, sometimes not. now i just make them wiggle, and it's all good!

i had used infinidock as well as pkgbackup, and wasn't having any issues at all till saturday night. the phone icon just went POOF. it didn't reboot, or respring itself. so i'm not sure what happened.

anyways, thanks again for the wiggle mode tip! :D
 

PinkBanana

Zealot
Gold
Feb 16, 2010
1,476
94
48
Burnley, UK
#8
I think that's what kept causing my contacts icon to disappear. I too have infinidock. No more though when my phone comes back from saq's.