Phone won't ring anymore!

Jul 30, 2008
11
0
0
#1
My 3G has stopped ringing! The speaker isn't broken... the iPod still plays through it, and when I check in settings to make sure my ringtones aren't set to silent, I can play all my ringtones.... they just don't play when someone calls me. Can't swear this coincided with the upgrade to 2.1 but it sure has happened since then. It isn't just my custom ringtones but all ringtones including the stock ones that came with the phone.

Anyone else had this happen? I searched the forum a couple of different ways but no hits.

Should I just return the phone to Apple for a replacement?
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#2
Relax, sounds like a very common problem caused by the phone kind of shorting out when you remove an earphone. Put your earphone back in the phone and remove it quickly several times. Than I would suggest turning the phone off and turning it back on again. That should do it.
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#3
You might also want to try going to Settings > General > Reset and Resetting All Settings. This solves many general problems including loss of sound as well.
 

iErik

Zealot
Gold
Oct 27, 2007
1,221
72
48
Las Vegas, NV
#4
Did you by chance hit the mute switch on the side of the phone? The iPod and sounds (in settings) will still play over the speaker when it's turned on.
 
Jul 30, 2008
11
0
0
#5
Thanks - resetting all settings didn't help, nor did turning the phone off & back on. Will try the earphone trick when I get back to my earphones again and hope that does it.
 

PapaST

Member
Bronze
Sep 10, 2007
458
6
18
#7
some time ago (before the 2.1 update) my wife's phone wouldn't play her custom ringtone (it would play all others). You could sample it but when you set it as a ringtone and someone called... no joy. I messed around with it and nothing would get it to work. After my 2.1 update recently I removed her custom ring and then added it back. After that it worked fine since.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#8
I'm putting my money on the headphone jack situation.
 

dieburnbot

New Member
Bronze
Sep 2, 2008
33
0
0
#9
My iPhone 3G did this too a couple of times, but all I did was reboot the phone and it has been fine ever since. Mine also did this weird thing where when I slid the slider switch on the left to vibrate the phone went insane. It start vibrating and playing my ringtone repeatedly and it wouldn't stop until I turned the phone off and turned it back on again. It's only happened to me once and it hasn't happened since I rebooted it. Not sure how that happened. Has it happened to anyone else?
 
Jul 30, 2008
11
0
0
#11
I'm putting my money on the headphone jack situation.
Yep, that's what it ended up being. Thanks to showguy for the quick and thorough response.

Yesterday was moving day and I was missing all kinds important calls so it was making me nuts!
 
A

autograf

Guest
#12
Mute Mystery

Thank you for saving ME a trip to the iPhone store! I didn't even know there was a mute button!... Dawn


Did you by chance hit the mute switch on the side of the phone? The iPod and sounds (in settings) will still play over the speaker when it's turned on.
 

julieb

New Member
Jul 8, 2010
5
0
1
#13
I tried both suggestions but neither one worked. I did use a generic headset with my iPhone a few days again. Any suggestions will be much appreciated! I have 3Gs unlocked, JB, upgraded 4.1.



My 3G has stopped ringing! The speaker isn't broken... the iPod still plays through it, and when I check in settings to make sure my ringtones aren't set to silent, I can play all my ringtones.... they just don't play when someone calls me. Can't swear this coincided with the upgrade to 2.1 but it sure has happened since then. It isn't just my custom ringtones but all ringtones including the stock ones that came with the phone.

Anyone else had this happen? I searched the forum a couple of different ways but no hits.

Should I just return the phone to Apple for a replacement?