Pink screen saying expired version of software

Jun 17, 2009
3
0
0
#1
I have been using 3.0 beta, but now i have a pink screen on my phone and iTunes says that that version of software i have been using has expired. my phone is unusable. I have been trying to download the official 3.0 version but have been receiving an error message. That stats, " there was a problem downloading the software for the iPhone. That requested source was not found." I have no idea what i should do. Can someone please give me some help.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#2
Have you tried restoring?

^ if restoring works then perform the restore and back-up once completed, that way you'll get your settings back :)

Let us know if you still have problems
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#3
Reinstall 3.0 official release. The pink screen you are seeing isn't too much of a problem. As ipw said above. You need to plug into iTunes and then restore to 3.0. Should fix it
 

Nils

New Member
Jun 22, 2009
2
0
0
#4
Same problem

I've got the same problem, connect it to iTunes (either on PC or mac) and I get the same message.

If I try restoring I get a message saying "There was a problem downloading the iPhone software for the iPhone. The requested resource was not found.

Restoring using XCode / Organizer seems to work, I does everything like expected but after the restorte the problem is the same.

I was running beta 5 for a few weeks and it worked fine. I had one problem though, I had installed a new test version of our software on the iPhone and one of my co workers, tried to download the current version from the app store (which lead to a crash and a blank icon with text "Waiting" remained on the phone since then)

My phone is completely useless now (except for emergency calls).

Please help
 

iPhoneMonster

New Member
Bronze
Jan 18, 2009
461
0
0
#5
Have you tried restoring?

^ if restoring works then perform the restore and back-up once completed, that way you'll get your settings back :)

Let us know if you still have problems
+1 on that one. That's what I'd do, then if that'd didn't work I'd ask on eic :)
 

Nils

New Member
Jun 22, 2009
2
0
0
#6
As said in my post I've tried restoring (the button in iTunes / device / summary that says Restore) and I even tried restoring using XCode / Organizer, that didn't work so I posted on eic.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#7
try putting the phone in DFU mode then connect to iTunes, it should say you need to restore phone and walk you through it.