Please Help... 2.2.1 update problems

Nov 17, 2008
18
0
0
#1
Hello,

I did not realize Apple released an update until yesterday. So seeing that 2.2.1 is available I decided to upgrade.

I restored and updated my jailbroken 2.2 3g. Downloaded the latest QuickPwn for mac. And ran it.

I can not get past the QuickPwn is about to run on your iPhone screen. This is after you turn it off, hold down power and home for 10 sec and then home for 5.

I eventually have to force quit QuickPwn and then I can restart my iPhone.

I have jailbroken my phone on 2.1 and 2.2 using this method so I do not know what I would be doing wrong.

Did this happen to anyone else?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#2
OS 10.5.6 breaks DFU.

you can try this, or plug your iPhone in through a usb hub (instead of directly to your mac). Both have worked for some, and not for others.

and, of course, the official dev team response:
"
Fixing DFU mode on 10.5.6
As noted previously OS X 10.5.6 introduced a bug that affected the use of DFU mode. with some Macs. There have been previously published hacks and techniques to fix this, but here is another method that can be used to temporarily restore DFU functionality in order to use QuickPwn or PwnageTool.

  1. You will need an account with ADC (Apple Developer Connection) this is free and takes a few minutes to sign up, you should read the terms and conditions carefuly and you should only sign up if you are thinking of developing applications in the future - http://[URL="http://is.gd/hN26"]developer.apple.com/mac/ [/URL]
  2. Download the disk image “IOUSBFamily-315.4-log.dmg” for Mac OS X 10.5.5 Build 9F33” (yes, that is a “5” in 10.5.5 - this is a developer debug package of the USB kernel extension).
  3. Unplug non-vital USB equipment, such as external DVD writers, USB scanners, USB mass storage devices, at the most leave a Keyboard and Mouse connected.
  4. Install IOUSBFamily-315.4.1.pkg from within the disk image
  5. Reboot your system!
  6. Perform necessary DFU activity with QuickPwn or PwnageTool.
  7. Download the disk image IOUSBFamily-327.4.0-log.dmg” for Mac OS X 10.5.6 Build 9G55”
  8. Intall IOUSBFamily-327.4.0.pkg from within the disk image
  9. Reboot your system!
  10. Reattach your USB peripherals."
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#3
I ran into the same problem, as all with the new MacBook's do, and just restarted the phone and then JB it on my Windows PC. You could try using a USB hub, it's supposed to allow you to circumvent the broken DFU mode. This apparently was not done intentionally by Apple and will be fixed with the next Mac Os X update.