Please help! iPhone 4 in DFU mode, error message with iTunes when trying to restore

Aug 1, 2011
4
0
1
London, United Kingdom
#1
I have just bought an iPhone 4 version 4.3.3 (with baseband 04.10.01 – i think!) from ebay which was working fine until I tried to jailbreak it using ‘redsn0w_win_0.9.6rc19′ with firmware ‘iPod4,1_4.3.3_8J2_Restore’. It didn’t work and all i was left with was the Apple logo stuck on the screen. After trying various things I have now managed to put it into DFU mode (the screen is totally black and not showing the iTunes usb cable), again using redsn0w. So next I open iTunes and it tells me that the phone is in recovery mode. I hold the shift key down and press the ‘restore’ button and select firmware ‘iPod4,1_4.3.3_8J2_Restore’ but get the following error messaage “The iPhone could not be restored because the firmware file is not compatible” – any ideas what I am doing wrong? thanks in advance for your help.
 
Last edited by a moderator:

Edge1978

Member
Bronze
Feb 7, 2009
245
5
18
#2
If you have an iPhone 4, you would need to restore it with iPhone 4 firmware, not iPod. However Apple is no longer signing 4.3.3, unless you saved your blobs, which I am only assuming you didn't, I don't believe you can downgrade to 4.3.3.

The firmware you need can be found here.
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,881
2,051
113
Florida
#3
It would have been so much easier to have just used jailbreak me.com when you had 4.3.3
If you do get it back to 4.3.x try that. Unless your needing to use Redsnow for a particular reason.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#4
You are using an iPod firmware - this is user error im afraid. You are trying to restore to the wrong device's firmware!

O_o
 
Aug 1, 2011
4
0
1
London, United Kingdom
#5
Of course! How stupid of me, I just followed a link and didn't even click that it was for Ipod! I wasn't using Redsn0w for any reason, I just stumbled across it.

I have now downladed iPhone3,1_4.3.3_8J2_Restore - but am I right in thinking this is for iPhone 3 and not iPhone 4? I basically just want to get this iPhone working again, and I don't care what version it's on, or if it's jailbroken, I would just like it to turn on! Any advice? thanks again, Lynn :)
 

fijiman

Contributor
Silver
Feb 13, 2011
832
64
28
UK
#6
iPhone3,1_4.3.3_8J2_Restore = iPhone 4
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#7
Of course! How stupid of me, I just followed a link and didn't even click that it was for Ipod! I wasn't using Redsn0w for any reason, I just stumbled across it.

I have now downladed iPhone3,1_4.3.3_8J2_Restore - but am I right in thinking this is for iPhone 3 and not iPhone 4? I basically just want to get this iPhone working again, and I don't care what version it's on, or if it's jailbroken, I would just like it to turn on! Any advice? thanks again, Lynn :)
No you have the correct firmware for the phone, however, you have downloaded 4.3.3 - unless you have your blobs saved then Apple are no longer signing this firmware and your restore will fail. The latest firmware is 4.3.5 and you just need to plug into iTunes and hit restore. You will download the correct firmware and build through iTunes and it will restore to stock. You will then need to jailbreak if possible.
 
Aug 1, 2011
4
0
1
London, United Kingdom
#8
Thanks for your advice. I tried restoring it via iTunes with firmware 4.3.5 it all seemed to be going ok but then at the very end of the restore I got the error message "the iPhone could not be restored. An unknown error occurred (3194)" - any ideas? thanks again :)
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#9
Thanks for your advice. I tried restoring it via iTunes with firmware 4.3.5 it all seemed to be going ok but then at the very end of the restore I got the error message "the iPhone could not be restored. An unknown error occurred (3194)" - any ideas? thanks again :)
did you change your systems host file to try and restore using Cydia’s SHSH caching server?
 
Aug 1, 2011
4
0
1
London, United Kingdom
#10
ended up taking it to the Apple shop and they managed to successfuly restore it. They said I did everything right to restore it but for some unknown reason a system restore sometimes fails on a pc but works better on an iMac? Thanks for all the help and advice anyway - much appreciated. I've ordered a gevey sim now to try and unlock it as the restore took it to version 4.3.5