Please help, jailbroken iPhone 3G black screen of death

#1
If anyone has the time or an idea.

Got an iPhone 3gs from a friend; happy to join the bandwagon as all other phone OS's have severely disappointed me.

The phone was jailbroken with green poison (from the startup icon i could see). I tried a wipe via the settings menu and then it would freeze on startup. After many hours I got it back to normal using redsnow. However as I was on my way to the store something happened and now it is just a black screen. I have tried every piece of software I could find. irecovery, redsnow, black rain (wouldn't work asd.dll thing), green poison and nothing works. All i want is to get it to 4.3.5 via Apple iTunes at this point but i get the error 16xx. Yes I have used tiny umbrella to no avail. iREBr4 doesn't seem to help either :(

The ONLY reaction I have got from the iPhone is using irecovery 421 and then I get a white screen but nothing else. At this point redsnow gets stuck in a waiting to reboot mode. Can anyone please have a tiny tidbit for me? I repent for all my Apple jailbreaking sins and promise to stand in line for the iPhone 5.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#3
Did the previous owner install the iPad's baseband? If he/she didn't, put the phone into DFU mode and restore through iTunes.
 
#4
Ah sorry for the wrong thread post. As best to my memory no the baseband is still a 5.x number.

iTunes does see the phone but whether I try a restore through Apple or a downloaded ipsw (4.3.3 or 4.3.5) I get the same error 1600. It happens if I am using tiny umbrella or not. I can put it into dfu mode as well for other apps like redsnow or green poison. redsnow it hangs on waiting to reboot and green poison now manages to say jailbroken but all I end up with is a white screen. At this point I am only trying the jailbreak software to get the phone up and running to that I can use iTunes to bring it to 4.3.5 Im not big into the jailbreaking I just want the phone back to normal :)
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#5
So when you try to restore through iTunes to stock firmware you receive a 1600 error?

You mentioned iReb, have you used an older version? i.e RC3? Make sure you're running the latest version of iTunes as well.