private number

Agent6

New Member
Sep 29, 2008
21
0
0
New Jersey
#1
Hi, I just updated my 8g iPhone to a 2.2 version. I use to be able to make my phone number private. Since the update i can't do it anymore. The "off" is shaded grey under caller id and doesn't allow me to change it. Is there a way to hide my number and make it private?
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#2
Try resetting your phone.

I just tried and my phone still allows me to do this on 2.2.

If your phone still does this after the reset, I think you're having problems with AT&T and not the phone, because that menu is an AT&T feature...
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#3
I just checked it on my 2.2 firmware and the option to withhold the caller ID is available. I would do as suggested and try a reset and then possibly a restore.
 

ess_bee

Member
Bronze
Dec 16, 2008
152
0
16
UK
#4
I just checked it on my 2.2 firmware and the option to withhold the caller ID is available. I would do as suggested and try a reset and then possibly a restore.
In the UK, you can type "141" before the number and you callers number would be witheld. I haven't tried it on an iPhone but the "141" does work on my Nokia.

If you live in the UK, give it a try...
 

Picazzo

Zealot
Gold
Jan 21, 2008
2,808
15
38
Copenhagen, Denmark
#5
Hi, I just updated my 8g iPhone to a 2.2 version. I use to be able to make my phone number private. Since the update i can't do it anymore. The "off" is shaded grey under caller id and doesn't allow me to change it. Is there a way to hide my number and make it private?
Are you clean or jailbroken?