Problem with Wi-Fi connection

Discussion in 'iPhone' started by rocky_phone, Aug 8, 2007.

  1. rocky_phone

    rocky_phone New Member

    Joined:
    Jul 15, 2007
    Likes Received:
    0
    Hello guys, I just bougth my iPhone yesterday and I'm very happy. But the onl insue rigth now is that the iPhone sees my wireless connection in my house, but I don't now why, when ever I click connect it says unable to connect, please if someone can help to set up this I really appareciate it. Thanks a lot.

    Daniel Villar
     
  2. Pennys

    Pennys Member
    Bronze

    Joined:
    Aug 2, 2007
    Likes Received:
    0
    WiFi problem

    Hey
    I am having a similar problem. iPhone recognizes router but will not accept my password. And yes I have checked the password several times and it is correct. Any ideas?

    Any settings I need to change?

    Thanks in advance.
    Penny
     
  3. wacevedo

    wacevedo New Member

    Joined:
    Aug 13, 2007
    Likes Received:
    0

    Not sure if you have been able to fix this, but in any case the solution is to change the DNS setting in your iPhone to match the router ip address. There seems to be a problem with iPhone incorrectly select the modem as the DNS server.

    in your iPhone change the DNS address to either the IP address of your router (192.168.1.1 for linksys) or a public DNS server (208.67.222.222 using OpenDNS). Hope this helps.
     
  4. Tinman

    Tinman Evangelist
    Gold

    Joined:
    Jul 16, 2007
    Likes Received:
    183
    As an FYI the problems I had with DNS were resolved with the 1.01 iPhone update.

    Also, the iPHone did not incorrectly select the modem as the DNS server, at least not in my case. The modem/router's IP address is supposed to work as the DNS IP on the iphone--just like it does for my laptops and PCs connected to the same router.

    Before the 1.01 update my iPhone was able to receive the correct DNS IP via DCHP from the router--and he correct DNS IP was indeed the router's IP. It just wasn't able to use that IP for DNS, ergo the need to manually enter an ISP/public DNS IP. But again, I haven't had to do that since the update.


    --
    Mike
     
  5. joe

    joe New Member
    Gold

    Joined:
    May 5, 2007
    Likes Received:
    0
    You could also try changing the encryption the base station uses from WPA to WEP. Some base stations don't do WPA very well.
     
  6. Kriss

    Kriss Zealot
    Silver

    Joined:
    Jun 8, 2008
    Likes Received:
    121
    Go to Settings... Then Wi-fi... Turn Wi-Fi on.. You should see any available wireless signals listed. If there is a little lock symbol, it means it's a secured network and you will need a password/key to access it. If it is your own network and you see a lock, it is protected and entering your key may not work. The trick is.. to identify the type of security you are using. The iPhone's security must match the network. Your choices are WEP/WPA/WPA2 and the enterprise versions of WPA/WPA2. I normally choose WPA2 and use something simple to remember like my cell phone number or a similar number. This has to be set up in your router. You should be able to use 192.168.1.1 or 10.0.1.1 to access your router. These addresses change depending on the brand. Go into wireless security and set your type of security. If it's WEP, I would strongly suggest you change it to WPA or WPA2 at this time. It will save you the hassle of remembering this long randomly generated key. You may have to reboot your router after changing this setting. It will let you know.

    Now go into your iPhone Wi-Fi settings.. I've found that even if my wireless router shows up, it sometimes won't let me just click on it to connect. This is usually because the default settings for security don't match the router. Go to OTHER... Type in your wireless SSID exactly. (This IS case sensitive), Press on the security line..Select WPA2. All it will do is put a check mark on it, then press Other Network to return to the Wi-Fi page. At this point you can type in the security code you set in the router. Then just press JOIN at the bottom. If all goes well, you will be connected to your wireless network.

    Some networks are unprotected and you can access them without a password. Some networks show as unprotected but want you to go to a internet gateway to accept the owners terms and conditions. This is true in cases such as hotels. Simply open a web page, it will open on their gateway page. Supply their user name and password and you should be connected until you disconnect from it. Then you will have to go to the gateway again.

    I hope this helps someone who is having trouble connecting to Wi-Fi on their new iPhones.

    Regards.
     
  7. Kriss

    Kriss Zealot
    Silver

    Joined:
    Jun 8, 2008
    Likes Received:
    121
    Ooooops.. I think I posted this under the wrong topic.. I hope the moderators will be kind enough to correct my mistake. Sorry.
     
  8. jimmy-m

    jimmy-m New Member
    Bronze

    Joined:
    Jul 19, 2009
    Likes Received:
    0
    I've tried to connect to some Wi Fi networks. I have no trouble connecting to my secure network - that is how I actually do most of my surfing. I've tried connecting to open networks in city parks and at a friend's house with limited success. I have connected to the ones at the parks after several tries, but was unable to do so on the other one even though I was sitting right next to the router.

    Is this unusual? Could some setting have been wrong in the router? I have since switched it to a secured network and didn't try again after that.

    P.S. Yes, I DID have Wi FI turned on and it was set to ask to join networks.
     
  9. MoneyMaker79

    MoneyMaker79 Genius
    Gold

    Joined:
    Dec 15, 2008
    Likes Received:
    340
    To be honest, I am not sure on this one. I have had my fair share of experience with routers and connecting to wifi connections.

    Some connections are slower than others, or do not have much connectivity. As far as the router not being setup properly, not to sure on that.
     
  10. Matthew G. Richter

    Matthew G. Richter New Member

    Joined:
    Mar 2, 2010
    Likes Received:
    0
    The solution that worked for me was:
    1) Go to your Mac computer>Airport Utilities>Access>click the "+" button on lower right of screen>type in your phone's Wi-Fi Address>click Update
    2) To find your phone's Wi-Fi Address go to your iPhone>Settings>General>About>scroll down to "Wi-Fi Address"

    This solved the problem for both my 2G and 3GS phones. I now can use a password to access the network, and both my phones and my Macbook all connect no problem.
     
  11. optoson

    optoson New Member

    Joined:
    Aug 6, 2008
    Likes Received:
    0
    Getting the dreaded "Unable to join network "SSID" message when trying to join to every Wifi I try... thinking I have an antenna problem. Anyone else have this with their 4?
     
  12. Max Bemis

    Max Bemis New Member

    Joined:
    Jun 12, 2010
    Likes Received:
    0
    i don't know if it's the antenna. ever since i updated my ipod to 4.0, i've constantly dropped my wifi signal all day long. it was flawless on 3.1.3, but now it's a huge pain in the ass.
     
  13. dawiyo

    dawiyo New Member
    Bronze

    Joined:
    Dec 2, 2007
    Likes Received:
    0
    might want to try resetting your router.
     
  14. 420greg

    420greg New Member
    Silver

    Joined:
    Jun 26, 2007
    Likes Received:
    0
    I had to 'forget' all my wi-fi networks that came over from my 3g and re-add them.
     
  15. macpublish

    macpublish Member
    Bronze

    Joined:
    Jun 22, 2010
    Likes Received:
    0
    No problem here. It remembered the networks after the update and I did not have to renter passwords. I have an airport extreme base station--if that matters.
     
  16. Panache010

    Panache010 Member
    Silver

    Joined:
    Aug 19, 2007
    Likes Received:
    0
    Did you restore from a 3G back up? Could be a coincident but ppl who started a fresh phone seems to have less issues.
     
  17. Jaz0305

    Jaz0305 Member
    Bronze

    Joined:
    Jun 24, 2010
    Likes Received:
    0
    The best way is to restore as new phone, your apps will still be in iTunes.
     
  18. 420greg

    420greg New Member
    Silver

    Joined:
    Jun 26, 2007
    Likes Received:
    0
    Yes. It was from a 3g back up. I had to re-enter all the passwords but I guess my router had the macs address of the 3g phone.
     
  19. GSA190

    GSA190 Member
    Bronze

    Joined:
    Oct 29, 2007
    Likes Received:
    6
    I've searched the forum and no threads have solved my problem. I just purchased a new laptop. It told me to set up a Wi-Fi network, so I did. I set up a home network. I go to my phone and it tells me to enter the password. I entered what I thought was the password to the wi-fi. I double checked the password and tried again. Still no connection. I think went into the settings and found the network security key. I entered this key into the password field in my wifi settings on my iPhone4. The message "unable to connect to network" appears. Any solutions?
     
  20. Iloveiphones

    Iloveiphones Genius
    Platinum

    Joined:
    Aug 5, 2010
    Likes Received:
    234
    I believe it's on the router. On the back it should gave a WEP key


    Sent from my iPhone using iCafe app
     
Similar Threads
  1. skinsgamer
    Replies:
    2
    Views:
    889
  2. jareknyc
    Replies:
    1
    Views:
    712
Loading...

Share This Page