Question about going from 1.0.2 to 1.1.1

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

brent

New Member
Nov 12, 2007
11
0
0
#1
I just had a couple of questions about upgrading my firmware. Right now I'm using 1.0.2 unlocked to AT&T network only. I've had it for about a month to a month and a half now and it's been pretty stable.

I'm a bit confused about upgrading my firmware. I've read through the guides and all the different methods, but I'm still a little unsure as to which one I should use.

My main concern is that 1.1.1 is first of all very stable unlocked, and that second, there is MINIMAL risk in upgrading it to 1.1.1. I know that there's always some risk in something going wrong, but I want to make sure it's relatively safe and stable.

So basically, is it even worth it to upgrade to 1.1.1 right now, or should I just stick with my 1.0.2 until something better/safer comes along? If it IS worth it, then could someone please point me in the direction of the easiest, risk-free way to do so?

I've done my research, I'm not just being dumb and asking questions without searching for them first, but I just want to make absolutely sure as I don't know what I'd do with myself if I broke my iPhone or made it unlockable as that's the only way I can use it (parents pay for phone bill, don't wanna sign another 2 year contract).

Any advice or answers would be GREATLY appreciated.
 

jpm

New Member
Bronze
Aug 5, 2007
212
0
0
#3
I just upgraded to 1.1.1 form 1.0.2 because iPhoneringtonemaker now works for it. As long as you have not hacked it to work with a different carrier you should be fine.
 

brent

New Member
Nov 12, 2007
11
0
0
#4
I just upgraded to 1.1.1 form 1.0.2 because iPhoneringtonemaker now works for it. As long as you have not hacked it to work with a different carrier you should be fine.
Is it pretty stable? Do you regret upgrading at all? Thanks for the reply. Also, what method did you use? If you could post me a link I'd appreciate it.
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#5
if you are at all reluctunt, stay where you are at with 1.0.2. I just spent all day getting back to 1.0.2 from 1.1.2. What a nightmare. Of course other technically savvy upgraders haven't had any problems but i found that i wasn't able to have all the same mods i had previously so i went back to 1.0.2.
I have not found that firmware to be unstable at all. If so, just restore that firmware and its as good as new.... When something better and easier arrives, ill take the plunge...
 

brent

New Member
Nov 12, 2007
11
0
0
#6
if you are at all reluctunt, stay where you are at with 1.0.2. I just spent all day getting back to 1.0.2 from 1.1.2. What a nightmare. Of course other technically savvy upgraders haven't had any problems but i found that i wasn't able to have all the same mods i had previously so i went back to 1.0.2.
I have not found that firmware to be unstable at all. If so, just restore that firmware and its as good as new.... When something better and easier arrives, ill take the plunge...
Thanks for the reply. After thinking it over, I think I'll just stay with my 1.0.2. If it ain't broke, don't fix it, right?
 

jpm

New Member
Bronze
Aug 5, 2007
212
0
0
#7
No problems with 1.1.1 and I like the new features that 1.0.2 did not have. If you have iTunes 7.5 you can make your own tones (There is a thread about how to do it) or use ringtonemaker which is what I use.