Rintones on 1.1.1 help

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Jun 7, 2007
545
0
16
Queens, NY
#1
so I followed "the guide" on modmyiPhone.com to "put" ringtones on my iPhone
so i did what they said....made the ringtone.m4a and the spoof.m4r file. now that file is just a blank text document? and yes i did modify the ringtone.plist and changed it the way they said to do....so what did I do wrong? the ringtone does not show up...i used winscp to place it where it had to go...the song i made into a ringtone...yes it was made into a 128kbs aac file and the track length was 27.453 seconds.... so where did i go wrong? any help would be nice.
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#5
I am using SendSong 0.17 Experimental from here:
http://ericasadun.com/ftp/Applications/SendSong/

This has worked for me, and it even creates the spoof .m4r file. Ringtones are still blown out after syncing, but I use a Tapp command to restore my working plist.

Just add the appropriate ringtone (has to be a .m4a file) to your iPhone playlist, sync, and then run SendSong to send the song to ringtones. Works for me on 1.1.1.



--
Mike
 

thegasguru

New Member
Bronze
Jun 27, 2007
180
0
0
#7
I havnt updated to 1.1.1 yet so I'm not quite sure how it handles stuff like that.
This thread will help a lot. Read the whole thread, especially the file naming info on page 4.

http://forums.everythingicafe.com/threads/custom-ringtone-for-1-1-1-for-pc.13068/

PS - the spoof files do not have to be named "spoof" (see above thread). Also, although the spoof files are zero byte (empty) txt files that you create with Notepad (or whatever app), they SHOULD be named with the .m4r extension.
 
Last edited by a moderator:

EvilRufusKay

New Member
Bronze
Sep 28, 2007
30
0
0
#8
I am using SendSong 0.17 Experimental from here:
http://ericasadun.com/ftp/Applications/SendSong/

This has worked for me, and it even creates the spoof .m4r file. Ringtones are still blown out after syncing, but I use a Tapp command to restore my working plist.

Just add the appropriate ringtone (has to be a .m4a file) to your iPhone playlist, sync, and then run SendSong to send the song to ringtones. Works for me on 1.1.1.



--
Mike
Is this an app for the phone itself using installer? I cant get it to run on my pc....
 

EvilRufusKay

New Member
Bronze
Sep 28, 2007
30
0
0
#10
No it runs on the iPhone itself. The iPhone has to be jailbroken to do so.



--
Mike
Sorry for the lame question I am about to ask but... How do I go about loading the app into the installer?

Mr. TinMan Sir,

Thank you very much for your efforts and time in helping those of us that like to mess with gadgets that we know little about. I am an Engineer but without the help of yourself and others like you I would be stuck with a stock phone. Thanks again!
 

SoleAddict23

New Member
Bronze
Sep 16, 2007
46
0
0
#11
I am using SendSong 0.17 Experimental from here:
http://ericasadun.com/ftp/Applications/SendSong/

This has worked for me, and it even creates the spoof .m4r file. Ringtones are still blown out after syncing, but I use a Tapp command to restore my working plist.

Just add the appropriate ringtone (has to be a .m4a file) to your iPhone playlist, sync, and then run SendSong to send the song to ringtones. Works for me on 1.1.1.



--
Mike

is this the same SendSong under installer on the iPhone? because through installer it reads SendSong 0.09.

but i downloaded the SendSong through installer, am i suppose to go with the SendSong 0.17 experimental? is it suppose to work with PC, windows users?

i've changed the appropriate ringtone that i want for my iPhone into .m4a but whenever i try to drag into my iTunes playlist to sync into my iPhone, it won't let me. is it suppose to be .m4r?
 
Last edited by a moderator:

EvilRufusKay

New Member
Bronze
Sep 28, 2007
30
0
0
#12
Yeh I am still having trouble myself. From what TinMan said, you download the experimental via a PC then send it to installer via WSCP. However, when I access the app on the phone it just hangs on a white screen. I must be screwing it up somehow...
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#15
Yeh I am still having trouble myself. From what TinMan said, you download the experimental via a PC then send it to installer via WSCP. However, when I access the app on the phone it just hangs on a white screen. I must be screwing it up somehow...
You need to set the permissions first. Open the SendSong.app folder via WinSCP, right-click the sendsong file, choose Properties, and enter 0755 in the octal value.

You should then be able to run it.

BTW: SendSong is up to 0.19 right now. It can now use MP3s for ringtones.



--
Mike
 
Jun 7, 2007
545
0
16
Queens, NY
#17
You need to set the permissions first. Open the SendSong.app folder via WinSCP, right-click the sendsong file, choose Properties, and enter 0755 in the octal value.

You should then be able to run it.

BTW: SendSong is up to 0.19 right now. It can now use MP3s for ringtones.



--
Mike
Well i did what you said, installed sendsong and it did work. The song appeared in my sound list in settings but even when i select the tone as my default tone it does not play when a call comes through, just a stock ringer plays. Any thoughts on that? The song does play when highlighted but not when a call comes in or even if I assign it as a tone for a contact....do i have to restart the phone?
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#19
Well i did what you said, installed sendsong and it did work. The song appeared in my sound list in settings but even when i select the tone as my default tone it does not play when a call comes through, just a stock ringer plays. Any thoughts on that? The song does play when highlighted but not when a call comes in or even if I assign it as a tone for a contact....do i have to restart the phone?
Yes, this is common when adding ringtones in 1.1.1: they show up in settings but do not play. You can either try renaming the files, and editing the plist to reflect it, or deleting the ringtone and try installing it again.

If a ringtones plays fine in settings, but doesn't play for an incoming call, reset the iPhone (turn it off, then on).



--
Mike
 

Doby45

Member
Silver
Aug 21, 2007
543
0
16
Powder Springs, GA
#20
If a ringtones plays fine in settings, but doesn't play for an incoming call, reset the iPhone (turn it off, then on).
Just for confirmation Tinman is 100% right on this. I just downloaded the newest Sendsong for 1.1.1 and was able to send the ringtone to my phone and assign it and could play it in the ringtone selection screen. But it would not play when the phone was called. Rebooted phone and now all is good. Thanks Tinman.