Safari 8.0 on OS X 10.10 fails to remove a single stored username/password when requested

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,254
113
44
Miami, Florida
#1
Have any of you tried to remove a single entry from the KeyChain (Safari > Preferences > Passwords) and found that Safari ignores your request?

I have two usernames ans passwords stored under two entries for www.facebook.com, as you can see below. The second of the two is outdated. When I highlight it and click "Remove," absolutely nothing happens.

safaripasswords.jpg


If I type "facebook" into the search field, and I don't highlight one specific entry, the button says "Remove All" instead of "Remove." However, clicking on that button shows the following ominous warning:

Remove All.png


I am afraid to click on "Remove All" because I have no guarantee that it will remove only the *.facebook.com entries and not remove all of my stored usernames and passwords (i.e., for every single site). Have any of you tried the "Remove All" button and successfully removed only the usernames and passwords for sites matching what you've typed in the search field?

UPDATE: This bug was not fixed by OS X 10.10.1. Going to submit a bug report.
 
Last edited: