Safari doesn't work anymore

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#1
I don't use safari all that much, but this morning when I attempted to start it, it sat there with a blank screen for about 5 seconds and then shut down.
Tried again, tried hitting the bookmarks tab, same thing.
Rebooted phone tried again...same ending.
Went to cydia removed any safari plugins rebooted opened safari...same thing.
Went into settings cleared history, cookies and cache, rebooted phone....same thing.
Attempted to open safari from a link in an email, same thing.

I've tried using wifi and edge (no 3G in my area) no joy. I've removed every app I have installed since the last time safari worked for me, no joy. All other apps that use the internet work just fine. I'm afraid I'm going to have to restore, big pain in the ass, anyone have any other suggestion before I go that route?
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#2
I would go to settings > general settings > reset then try reset network settings, or reset all settings for better results. If that doesn't work, its a restore job!
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#3
Thanks, got it working, I had forgetten one plug-in I had...after removing the ad-block plug in it worked fine, kinda pisses me off though, I paid for the ad-block plug-in and now I can't use it.
 

andyveale

Member
Bronze
Jan 13, 2009
38
0
6
#4
Thanks, got it working, I had forgetten one plug-in I had...after removing the ad-block plug in it worked fine, kinda pisses me off though, I paid for the ad-block plug-in and now I can't use it.
Hey I'm having the same problem... I have Ad Block as well, do I have to uninstall it?
 

andyveale

Member
Bronze
Jan 13, 2009
38
0
6
#5
I've just uninstalled it and now Safari works. This is pure trash. I don't have the paid version, and it was about a month ago that I downloaded it. I'm willing to bet the devs of that app lock you out after a certain period of time.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#6
I don't know all I know is I paid for it and now it caused safari no to work. Being on edge most of the time, it was helpful in page load times and who wants to look at ads anyway. I will just have to chalk this up as a learning experience.
 

andyveale

Member
Bronze
Jan 13, 2009
38
0
6
#9
It blocks most ads (banners, text, etc) in web pages
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#10
You entered in your code right?
Yes, I did, the thing is, even if I didn't...it shouldn't prevent safari from working, it simply wouldn't do its job and wouldn't block ads. It can't be an issue with the 2.2.1 upgrade cause it has worked just fine since, until today.
 

andyveale

Member
Bronze
Jan 13, 2009
38
0
6
#11
I find that interesting, that we both have Ad Block and it stopped working today... maybe it's a database issue.