Screen not responding...

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#1
This is rather strange. Since this morning, my iPhone's screen has decided to to respond. Just blackness. It's not as if it's off or in DFU, however, as it still chirps when it's docked, and still rings when it's called. However, there is no response on the screen and all is dark. Any ideas?
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#2
Hmm...
Restore?
...but I don't think it'll help. Sorry.
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#3
There must be another way. Resorting is quite a pain when you've done all the mods I have going. :(
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#4
Well, lets say restoring could fix the problem.
What's better? Being able to see those mods (well, after re-doing everything) or not being able to use the entire phone period?
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#5
When my phone acts like that (temporary black screens) I plug it into the computer or car or outlet and everything pops back into order. Then reboot the phone and all should be well. If not...time for the dreaded restore.....

any recent installations of apps? swap some stuff around in winterboard...turn stuff off...reboot try again...
 

Ramesh

Zealot
Gold
Jul 12, 2007
4,571
3
38
Irvine, Ca.
#6
I've had that happen. What I did was force kill the phone. You know the steps but - press and hold the home and power button until it reboots... That fixed it for me.
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#7
I've tried that as well. It won't shut off. I get a version of this a lot - it won't respond, but docking it wakes it up and all is well. But now, docking it only makes it chirp and it's still black. iTunes recognizes it perfectly; there seems to be no problem with it other than the screen.

And of course, I have SSH turned off right now. Otherwise, I would go in and reboot through the Terminal, but not possible right now.
 

Ramesh

Zealot
Gold
Jul 12, 2007
4,571
3
38
Irvine, Ca.
#8
I've tried that as well. It won't shut off. I get a version of this a lot - it won't respond, but docking it wakes it up and all is well. But now, docking it only makes it chirp and it's still black. iTunes recognizes it perfectly; there seems to be no problem with it other than the screen.

And of course, I have SSH turned off right now. Otherwise, I would go in and reboot through the Terminal, but not possible right now.
Hindsight's 20/20 - but why bother turning off SSH? It doesn't drain any more than normal, IMO.

Well - Try this. Have it die completely and THEN try to redock.
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#9
Fixed. I was able to get into it with DiskAid and then I deleted all of WinterBoard's components. I was able to hard reset, booted into Safe Mode, rebooted, replaced WinterBoard, and all is well.
 

Ramesh

Zealot
Gold
Jul 12, 2007
4,571
3
38
Irvine, Ca.
#10
Fixed. I was able to get into it with DiskAid and then I deleted all of WinterBoard's components. I was able to hard reset, booted into Safe Mode, rebooted, replaced WinterBoard, and all is well.
Cool. Glad to hear it. I'm always annoyed by the people who say "restore" to every question. For Example:

Safari crashes every once in a while...
Restore!

I can't find my car keys...
Restore your phone!