Screenshot and 1.1.3 *WARNING*

x666x

New Member
Bronze
Jan 24, 2008
443
0
0
#1
The Short Version:

Restarting your iPhone/Springboard with Screenshot still running will ultimately disable all of your onscreen buttons, save for launching apps. You will not be able to press anything inside of any app and will have to force quit it to exit.

To fix it, you need SSH running and then must browse to:

/usr/bin/

and delete the screenshot folder there, (/usr/bin/screenshot)

After that, restart your phone and you should be back to normal.

IF YOU DO NOT HAVE SSH RUNNING

Try to sync and backup because guess what? Its time to restore and rejailbreak :(


The Long Version:

I ran into a really strange problem lastnight when I was trying to take some screenshots of my Summerboard theme... Basically I had 2 versions, a color and a "dim" version that I wanted to take screenshots of. With screenshot still running, I swapped out one theme for another causing my Springboard to automatically restart itself and make the next 30 minutes interesting to say the least.

Once I came back from the restart everything looked fine, but pressing the Screenshot buttons wouldn't do anything. I could launch programs, but tapping anything inside their app windows wouldn't work. I couldn't uninstall Screenshot because after launching Installer I couldn't tap the uninstall button, just launch, look and exit. Thats all I could do!

I had the idea to see if SSH was on, luckily it was. I deleted the Screenshot preferences plist file, as well as removing the screenshot.app folder from my applications directory. I powered down and crossed my fingers... Great, now I have a flickering Apple logo and white lines scrolling up my screen! That didn't fix it, it just made it worse! Putting the files that I removed back on through SSH fixed it, and got me back to a phone without buttons.

I was out of ideas and decided to see if there were any processes I could force quit out of... SSH in through my Mac, check the processes and blammo, I see /usr/bin/screenshot in use. I force quit the job number and subsequently lock up my phone... Time for another restart! This time around, instead of force quitting, I just deleted the /usr/bin/screenshot directory and restarted the phone one last time. SUCCESS! I then proceeded to uninstall Screenshot. Powered up/down and my phone is back to normal. I've since put Screenshot back on, but I know better than to restart with it still running ;)
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#2
I've seen very similar issues with Screenshot in previous firmware versions as well. I've never had to uninstall it - have generally got past it with a hard reset or two.
For a long time now I am in the habit of closing Screenshot as soon as I'm done using it. It's a great app, but not one to leave running for sure ...
 

x666x

New Member
Bronze
Jan 24, 2008
443
0
0
#3
I restarted quite a few times, and unfortunately the problem never resolved itself :T

In fact, the only way I could restart the phone was by holding the power and home button together >.>

BossPrefs was updated soon after my debacle, I wonder if it has a failsafe for this now? The info said it did updated the way it detected the services, of which I've got the screenshot plugin installed and is how I turn it on and off.

Anyway, this sucked, glad its done and figured out now, heh.
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#4
Yup, it's a great app, but does not socialize well with others, or something like that :)

The other thing I've noticed with it, only since the 1.1.3 jailbreak (under Nate's and Dev Team method) is that it quite often snaps a screencap only once every two presses of the button. The View button is similarly not 100% responsive. I've never really looked into it much - uninstalled and reinstalled and it behaves the same, so it's not a big enough deal to worry about for now ...
 

jamesins

New Member
Mar 3, 2008
1
0
0
#5
tried all u said..still wont work

i installed screen shot and all my 3rd party apps were gone. what now? i deleted all the files i can find that refer to screen shot, but still they wont come back. solution?

james.spiteri@gmail.com
 

guest0320

Member
Silver
Nov 11, 2007
728
0
16
#6
I just dealt with this Piece of S app yesterday.
It leaves a nice turd that jams up your phone in usr/bin.
So follow the directions above.

I think this app should have a warning sticky here. I know of no other app that has created so much havoc, and completely screws up your phone.

Dana
 
Nov 24, 2007
319
0
0
#7
hmmm i thought my screen was broke again. thanks, thoses black & white lines were freaking me out.. thanks for posting that 666, THANK YOU! that saves me about 10 restores, theres no way i woulda knew that was my problem, if i had of knew that a week ago it woulda atleast saved me 5... thanks for posting that
 

Griffinaz

Zealot
Gold
Oct 5, 2007
1,046
13
38
Phoenix, Arizona
#8
Thank you for posting this. I wish I had known that back in December. Just like Patrickj, I had problems on an early firmware with the same thing and ended up with a half messed up phone because of it. I use Dock for screenshots now.
 
Last edited by a moderator:
Nov 24, 2007
319
0
0
#9
"i install a app and it just stays cloaking after i exit from installer, stays cloaking for 5 mins, so i turn it off and it stays in the Apple screen after i power on.. only way to fix it is restore.. this has happen twice" 3 times now! really pissed this whole problem was because of screenshots 1.3.0.... thank god its over:laugh2:

just SSh in & delete the app u installed (TO FIX LOADING PROBLEM),then once u can use installer again uninstall it & screenshots