Sending text message with Contacts

jacjac2

New Member
Bronze
Jul 1, 2007
99
0
0
60
Texas
#1
I have done a search and can not find the info so here goes. I am in my contacts and want to send a text message from within a contact. I click on it and type the message and send. I then get a reply back in error that I need a ten digit number, showing that a "1" was placed in front of the number. My contact does not show a "1". Am I missing preference somewhere, even in my original Address Book.

Jackie
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#2
I have done a search and can not find the info so here goes. I am in my contacts and want to send a text message from within a contact. I click on it and type the message and send. I then get a reply back in error that I need a ten digit number, showing that a "1" was placed in front of the number. My contact does not show a "1". Am I missing preference somewhere, even in my original Address Book.
I couldn't replicate that problem.

I tried using a test contact, with the phone number going to my Sprint Treo, using the following scenarios:

* International Assist on and off.
* Phone number entered as ###-###-####
* Phone number entered as 1-###-###-####
* Phone number entered as ###-#### (Sprint phone is same area code where iPhone is located.)

No matter what I did the text messages went through. I was actually surprised that ###-#### worked since my Sprint phones won't work with that, even in the same area code (if I try it I get an SMS back saying "Message sent using invalid number of digits. Please resend using 10 digit number of valid short code.").


--
Mike
 

jacjac2

New Member
Bronze
Jul 1, 2007
99
0
0
60
Texas
#3
I am testing one now, got tip from someone to check in my original address book. In there, I had put "1" before numbers when dialing. I unchecked that, did another sync and trying that out. I will let you know if that works. Thanks for the reply.

Jackie