Serious Problems on the eiC Safari Mobile Template

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#1
The keyboard locks up when I'm using eiC on Mobile Safari at least once a day. It sometimes happens constantly. The entire screen becomes unresponsive. I have to use the home button to launch task switcher and quit Safari or just wait for Safari to crash. It's happened since 8.0, but it's getting worse.

Also, avatars are screwed up. I have Hippo's. Kadelic has an emoji face. Kadelic is in the emoji list. Kadelic is in the middle of a lot of Rafagon's posts.

Is anyone else experiencing these problems? PLEASE, only reply if you are using mobile Safari. These problems don't occur on computers or the app.
image.jpg image.jpg image.jpg image.jpg
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#6
Any problems on other sites, or is it eiC specific?
No problems on other sites or in any other apps. It's eiC and mobile Safari-specific for me.

It's frustrating because I have to retype my posts a lot. It doesn't always save it as a draft when it locks up and crashes.
 

chris

Administrator
Administrator
Jun 10, 2006
11,812
1,778
113
Long Island, NY
#7
No problems on other sites or in any other apps. It's eiC and mobile Safari-specific for me.

It's frustrating because I have to refuse my posts a lot. It doesn't always save it as a draft when it locks up and crashes.
  • Is it specific to Safari?
  • Does it only happen while editing/composing a post?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#8
I guess Benny confirmed that the avatar problem is on the app, too. I haven't tested the app yet.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#11
can't say I've experienced any of those issues. Don't come here a LOT on my phone, but often enough.
I'm going to have to test mobile Chrome as the lookups have gotten much worse lately and happen several times a day. I was going to restore to factory settings as well, but wanted to find out if anyone else is having these problems first.

You have rom x's bitcoin avatar.
image.jpg
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,804
982
113
65
Florence, AL
#13
I've seen the avatar issue before. It's been a while though. It was on the eiC app. Someone else had my avatar, and I thought it was intentional to be funny. But then I saw it again with someone else. That was several months ago. I've been using Tapatalk a good hit lately, and haven't seen any avatar issues with it.


Sent from my ancient but trustworthy iPhone 5.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#14
The avatar problem really isn't a big deal to me, though it is odd. The lockups on the other hand are driving me crazy. I never know if I'm about to lose everything I just typed and have to start over. I'm not sure if it's eiC or iOS, but I'm going to restore to factory settings tomorrow to rule that out. Thanks for all your help with this, @chris.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#15
The avatar problem really isn't a big deal to me, though it is odd. The lockups on the other hand are driving me crazy. I never know if I'm about to lose everything I just typed and have to start over. I'm not sure if it's eiC or iOS, but I'm going to restore to factory settings tomorrow to rule that out. Thanks for all your help with this, @chris.
I've experienced these lockups when I'm in the middle of composing a post and the site would just freeze. I have to copy and paste what I wrote and start a new post. It's actually frustrating and I thought it was an issue with mobile Safari so I went back to using the app. The app also suffers from lockups. As an example, I was starting a new topic and the app just crashed in the middle of typing it out. I didn't have time to save anything and so I had to start over. As a side note, I've had more issues on the mobile Safari and app side since the last forum upgrade.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#16
I've experienced these lockups when I'm in the middle of composing a post and the site would just freeze. I have to copy and paste what I wrote and start a new post. It's actually frustrating and I thought it was an issue with mobile Safari so I went back to using the app. The app also suffers from lockups. As an example, I was starting a new topic and the app just crashed in the middle of typing it out. I didn't have time to save anything and so I had to start over. As a side note, I've had more issues on the mobile Safari and app side since the last forum upgrade.
My screen completely freezes. I am unable to copy the text I had written. The only things I can do are repeatedly tap the unresponsive screen until Safari crashes or use the home button to activate the task switcher and force quit Safari. Sometimes a draft of what I had written was saved. Other times I have to completely rewrite my post. Is this what happens to you or are you able to copy your text? Maybe you meant copy it down on paper.

I have never had it happen on another forum. Have you?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#17
I just reset all settings on my phone and the avatars are correct now.

Some other things I should mention are that I don't have any third party keyboard apps installed and I have cleared my cache in mobile Safari several times over the past week, but I still experienced the problems with avatars and frequent lockups while typing on eIC.
 

chris

Administrator
Administrator
Jun 10, 2006
11,812
1,778
113
Long Island, NY
#18
I think it might be because you've got an iPhone 6. Clearly, these problems would happen on the iPhone 6 Plus.*


*Bringing levity to a stressful situation.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#20
My screen completely freezes. I am unable to copy the text I had written. The only things I can do are repeatedly tap the unresponsive screen until Safari crashes or use the home button to activate the task switcher and force quit Safari. Sometimes a draft of what I had written was saved. Other times I have to completely rewrite my post. Is this what happens to you or are you able to copy your text? Maybe you meant copy it down on paper.

I have never had it happen on another forum. Have you?
Yeah. That is what happens and I force quit Safari. I've only encountered this on the eIC forum.