Serious Problems on the eiC Safari Mobile Template

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#41
Have you tried using chrome to see if you get the results?
Chrome doesn't support the swipe gesture. I can't live without that. I think Apple is purposely hobbling it to get people stick with Safari. I plan on jailbreaking when the Mac version is ready, and it has a swipe tweak for Chrome. I'll test Chrome with eiC after I jailbreak, which should be very soon.
Did you experience these issues on 8.0 or just 8.1? I remember having issues with the forums going back to 7.1.2 so I'm curious if this is an eIC related problem. It was still usable back then but now I get more lockups and Safari freezing in 8. I think one thing is for certain, the upgrade to 8.1 made my Safari experience worse. I'm unsure if it is eIC or Apple.
It has happened since 8.0 on my iPhone 6. It never happened on my 5s, which is still on 7.1.2.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,824
987
113
65
Florence, AL
#43
How often does Safari lock up on you?
Mostly when I enter my email address for log in or to register in to a site. Sometimes a page just freezes for no reason. But neither happens that often. It might with the log ins, but I don't do that much. It's where as soon as I type an E, it gets stuck with the E opened up. (See pic) But when it does that, I just close the app then open back up. No deleting in the app switcher. One thing (off topic) I've noticed is when I auto fill or use shortcuts to fill my email on some log ins, it says me email is not valid. I have to enter it in manually. I would say I get some type of freeze up maybe 4 or 5 times a week.
ImageUploadedByTapatalk1415386409.352067.jpg
 

chris

Administrator
Administrator
Jun 10, 2006
11,813
1,779
113
Long Island, NY
#44
Did you experience these issues on 8.0 or just 8.1? I remember having issues with the forums going back to 7.1.2 so I'm curious if this is an eIC related problem. It was still usable back then but now I get more lockups and Safari freezing in 8. I think one thing is for certain, the upgrade to 8.1 made my Safari experience worse. I'm unsure if it is eIC or Apple.
For the record, I've found numerous threads at Apple regarding Safari crashes. I'm not discounting that it could be us, but this isn't an incredibly stable browser.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#45
For the record, I've found numerous threads at Apple regarding Safari crashes. I'm not discounting that it could be us, but this isn't an incredibly stable browser.
Have you found anything specifically about lockups? Mine doesn't crash unless I repeatedly tap the unresponsive screen. Otherwise, I have to force quit Safari. Mine looks exactly like Ledsteplin's screenshot, only it happens when I'm typing on this forum instead of when I'm typing my email address.
 

chris

Administrator
Administrator
Jun 10, 2006
11,813
1,779
113
Long Island, NY
#46
I've been trying to reproduce the problem, but haven't had success. I'm sure it exists, I just can't make it happen. It appears to be related to Safari and javascript. I've skimmed this thread on Apple's forums.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#47
I've been trying to reproduce the problem, but haven't had success. I'm sure it exists, I just can't make it happen. It appears to be related to Safari and javascript. I've skimmed this thread on Apple's forums.
That's not the problem I am experiencing. I'm having the same problem Ledsteplin and Silvermoon are having. It does not happen when I use shortcuts. It does not affect links. I can't scroll to fix it. It locks up when I'm typing. A key stays stuck in the air. I have to force quit Safari to fix it. I haven't found a thread specific to the problem the three of us are having, but I know other people on eiC mentioned it shortly after the iPhone 6 came out when we were still on 8.0. At the time I just assumed it was a bug Apple would fix in 8.0.1.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#48
That's not the problem I am experiencing. I'm having the same problem Ledsteplin and Silvermoon are having. It does not happen when I use shortcuts. It does not affect links. I can't scroll to fix it. It locks up when I'm typing. A key stays stuck in the air. I have to force quit Safari to fix it. I haven't found a thread specific to the problem the three of us are having, but I know other people on eiC mentioned it shortly after the iPhone 6 came out when we were still on 8.0. At the time I just assumed it was a bug Apple would fix in 8.0.1.
That problem is related to Safari in general which is slow and freezes in 8.1. It doesn't address the problem that we are having when we are typing. The frustrating part of it all is that I have to force quit Safari and most of the time, I don't have time to save any of the contents before I post. There doesn't seem to be anything coming up when I do a Google search on this problem. Unfortunately, I don't know where you would look to fix it but it's a usability problem.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#49
That problem is related to Safari in general which is slow and freezes in 8.1. It doesn't address the problem that we are having when we are typing. The frustrating part of it all is that I have to force quit Safari and most of the time, I don't have time to save any of the contents before I post. There doesn't seem to be anything coming up when I do a Google search on this problem. Unfortunately, I don't know where you would look to fix it but it's a usability problem.
I don't have any issues with slowness. It just freezes. I don't even have any shortcuts or third party keyboards added to my phone. Since there is no way to predict when it is going to happen and the screen is unresponsive after it happens, there is no way to save your post aside from taking a screenshot. It's not a matter of having time. You will never have time to save it since you can't predict it. I've tried everything, including a restore to factory settings. Apple just can't get their browser right and they hobble third party browsers so we don't have good options. It took them six months to fix the Safari crashes that happened daily to a lot of us last year. I'm getting used to only having stability for half the year.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#50
I don't have any issues with slowness and I don't even have any shortcuts or third party keyboards added to my phone. It just freezes. Since there is no way to predict when it is going to happen and the screen is unresponsive after it happens, there is no way to save your post aside from taking a screenshot. It's not a matter of having time. You will never have time to save it since you can't predict it. I've tried everything, including a restore to factory settings. Apple just can't get their browser right and they hobble third party browsers so we don't have good options. It took them six months to fix the Safari crashes that happened daily to a lot of us last year. I'm getting used to only having stability for only half the year.
Are there any decent and working browsers that you have used? More specifically, that you have tested to see if this problem crops up in them too. I haven't had much time to test different browsers on the mobile version of eIC. I'm thinking we need to do some more troubleshooting to find what is causing the issue. Eventually, I'd like to pinpoint this problem to Safari and 8.1.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#51
Are there any decent and working browsers that you have used? More specifically, that you have tested to see if this problem crops up in them too. I haven't had much time to test different browsers on the mobile version of eIC. I'm thinking we need to do some more troubleshooting to find what is causing the issue. Eventually, I'd like to pinpoint this problem to Safari and 8.1.
I haven't tested any because I couldn't find any with native swipe. I'd rather deal with the freezes or just go back to a 5s that's on 7.1.2 than go without native swipe gestures on the browser on my 6. After I jailbreak, I'm going to install Chrome and the jailbreak tweak that enables swipe on it and I'll test eiC.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#52
Freshly restored to factory and still happening at least once a day. Usually on medium or long posts like this.
image.jpg
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#53
I have noticed that the wheel next to the WiFi symbol is often spinning when it locks up. It's spinning for me right now for no reason. It freezes along with everything else on the screen when it locks up.

I've had this page fully loaded for several minutes, yet it continues to spin. I'm not sure if that's bad forum software or a Safari glitch. But a perpetual spin is a sign that something is wrong. I'll have to force quit Safari to get it to stop and I just force quit the app ten minutes ago when it froze.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,824
987
113
65
Florence, AL
#54
I have noticed that the wheel next to the WiFi symbol is often spinning when it locks up. It's spinning for me right now for no reason. It freezes along with everything else on the screen when it locks up.

I've had this page fully loaded for several minutes, yet it continues to spin. I'm not sure if that's bad forum software or a Safari glitch. But a perpetual spin is a sign that something is wrong. I'll have to force quit Safari to get it to stop and I just force quit the app ten minutes ago when it froze.
I've noticed the wheel spinning for no reason. I hadn't connected it to the freezes. I'll watch for it. I hope Apple is aware of this and has a fix in the next update.


Sent from my ancient but trustworthy iPhone 5.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#56
@chris Avatars are messed up again. Ledstepplin has mine and Naps has an emoji face.
image.jpg image.jpg

And my Safari froze when I hit the backspace key while I was typing this message. That's the second time it's froze on me on eiC today. I just have non-stop problems on eiC, but I'm not sure what to do. I've already restored to factory settings. Do you have another mobile template I could test? See how the backspace key is highlighted? It doesn't raise up in the air like the other keys.
image.jpg
 

chris

Administrator
Administrator
Jun 10, 2006
11,813
1,779
113
Long Island, NY
#57
@Europa I don't think it's the template. I think it's something with Safari and iOS. What's troubling is that I'm unable to replicate the issue. We can try the default template, but I'll have to lock it down to the Off Topic section. That would take any customizations out of the equation, though the template designer said it's likely not the template. Since these crashes are happening in the editor, templates aren't playing a role.

I wonder why you're getting that spinning. I'll look at scripts loading and see if anything stands out. Are the crashes happening on WiFi, cellular or both?

Have you spent any time using Chrome? That would isolate the issue to the forum software, Safari, iOS 8.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#58
@Europa I don't think it's the template. I think it's something with Safari and iOS. What's troubling is that I'm unable to replicate the issue. We can try the default template, but I'll have to lock it down to the Off Topic section. That would take any customizations out of the equation, though the template designer said it's likely not the template. Since these crashes are happening in the editor, templates aren't playing a role.

I wonder why you're getting that spinning. I'll look at scripts loading and see if anything stands out. Are the crashes happening on WiFi, cellular or both?

Have you spent any time using Chrome? That would isolate the issue to the forum software, Safari, iOS 8.
I guess it isn't always spinning when it locks up. The one I had tonight wasn't spinning. I haven't used Chrome because it doesn't have swipe to go back. I guess I'll try to live without that for a while and test it.

It happens on WiFi and cellular.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#59
@chris I used mobile Chrome to check several new threads and make one post and it didn't lock up, but I can't stand to use it long enough to test it anymore. I'm too spoiled by Safari to deal with the lack of gestures and the harsh screen flashes as it loads pages.

I decided to give the iCafe app another try. It doesn't support swipe to go back to the new posts list. Swipe only takes you between different pages in a thread. I'm surprised app users aren't bothered by that. I guess they are just used to it since we've only had swipe for a year and they've been using the app longer than that. I'm pretty sure swipe works in Tapatalk, so I think I'll give that another try.