Serious Problems on the eiC Safari Mobile Template

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#61
I'm not seeing the "flash" in Chrome as it loads pages. Could you explain further?
The screen flashes black every time it loads pages. It's harsh. You don't see that?

And it lags on the first flick when you scroll and doesn't move much. Subsequent flicks scroll fine.
 
Last edited:

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#63
It has been my experience that the app is smoother and less problem-free than mobile Safari. I do wish that swipe would take you back to the list of posts. The other stuff that is missing from the app is the ability to "agree" with a post or mark the post as funny or informative. Oh, and being able to view the front page posts would be useful.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#64
It just locked up on mobile Safari AGAIN when I started typing this post. Napoleon thinks I should get my phone replaced by Apple because no one else here is having this problem and I've already restored to factory. I think the Genius is going to laugh at me when I say I need a new phone because a specific forum locks up on me constantly, but maybe this is a memory problem. The closest Apple Store is two hours away, but I guess I'll give it a try. Thoughts, @chris?
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#65
It just locked up on mobile Safari AGAIN when I started typing this post. Napoleon thinks I should get my phone replaced by Apple because no one else here is having this problem and I've already restored to factory. I think the Genius is going to laugh at me when I say I need a new phone because a specific forum locks up on me constantly, but maybe this is a memory problem. The closest Apple Store is two hours away, but I guess I'll give it a try. Thoughts, @chris?
It sounds like you are having problems every time you use Safari. That would be device specific and I'd get a replacement from Apple. I experience problems in mobile Safari but not all of the time, just intermittently.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#66
It has been my experience that the app is smoother and less problem-free than mobile Safari. I do wish that swipe would take you back to the list of posts. The other stuff that is missing from the app is the ability to "agree" with a post or mark the post as funny or informative. Oh, and being able to view the front page posts would be useful.
Could you do me a huge favor? Use eiC on mobile Safari for a couple days and see if you have the same problem I do? I'd really appreciate it. It's not when using a shortcut to input an email address, which is a known problem a lot of people have. It's just when I'm typing posts. It sometimes only happens once a day. Other times it's frequent. If it doesn't happen to you in two days, it probably won't happen.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#67
Could you do me a huge favor? Use eiC on mobile Safari for a couple days and see if you have the same problem I do? I'd really appreciate it. It's not shortcuts and it's not when typing email. It's just when typing posts. It sometimes only happens once a day. Other times it's frequent. If it doesn't happen to you in two days, it probably won't happen.
Sure. I can do that and report back my findings in a couple days.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#70
It sounds like you are having problems every time you use Safari. That would be device specific and I'd get a replacement from Apple. I experience problems in mobile Safari but not all of the time, just intermittently.
I really don't think this is hardware-related. It doesn't happen every time I use mobile Safari. I use Safari for several hours a day. It's never happened outside of eiC. At worst, it happened five times in one day. In September and October, it only happened one time a day or less. I had lots of problems with mobile Safari the first half of the year last year, but Apple fixed those with 7.1. I had tons of problems with Touch ID the first half of the year and everyone told me to get a new 5s. I knew it wasn't hardware so I Didn't replace it. Sure enough, Apple eventually fixed the Touch ID problems with a software update and it worked beautifully on my 5s after that. I think iOS (particularly Safari) is just buggy the first several months of the year.

Maybe it's because I type too fast? I'm trying to slow down my typing right now to test that. I've tested so much and I'm open to any ideas anyone has. I would love to be able to jailbreak now that the Mac version is out, but I don't want to until I can get my phone to stabilize when it's stock.

I really appreciate you testing it for me. Please take a screenshot if it happens.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#72
It's a shame it's such a short thread, though.
Yeah, I know I'm one of the only people having this problem. It makes it even more frustrating than it would be because I don't know if Apple is going to fix it if it's not common. For some reason, I'm always more affected by Safari bugs than most people. A lot of people have it happen, but only when they are using shortcuts to input email.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#74
My post wasn't supposed to be sarcastic. When I found the thread, I had hoped that it would have more info in it than what there was.
I just submitted a bug report to Apple today for the first time. I should have done this at least once on every firmware version it occurred on.

BTW, it happened to me TWICE while I was typing this post. That's probably the sixth time today on eiC. I've posted other forums today with no problem. It's only eiC.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#75
It seems to happen a lot more often when I type long posts. I think most people on eiC use Tapatalk or iCafe. Is there anyone else here who strictly uses mobile Safari for eiC and types long posts frequently?
 

chris

Administrator
Administrator
Jun 10, 2006
11,812
1,778
113
Long Island, NY
#76
I'm going to see if I can reproduce today using longer posts. This one is a tough one to nail down.

I'm going to make some changes to Off Topic later today so that we can run some tests there as well.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#77
I'm going to see if I can reproduce today using longer posts. This one is a tough one to nail down.

I'm going to make some changes to Off Topic later today so that we can run some tests there as well.
Thanks. It does seem to be Apple and not eiC. Another person just posted about it on that thread in the Apple forum.
https://discussions.apple.com/thread/6591506
 
Dec 10, 2009
2,589
1,337
113
52
Clarksburg, WV
#78
I don't recall experiencing your reported lockup issue while typing long post here using mobile Safari, but I am and have been seeing the weird avatar issue for weeks....

image.jpg
image.jpg


Those small avatars appearing in bottom left of my posts should be additional pix posted, not user avatars....
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#80
Could you do me a huge favor? Use eiC on mobile Safari for a couple days and see if you have the same problem I do? I'd really appreciate it. It's not when using a shortcut to input an email address, which is a known problem a lot of people have. It's just when I'm typing posts. It sometimes only happens once a day. Other times it's frequent. If it doesn't happen to you in two days, it probably won't happen.
I know it is kind of early to be reporting back but I want to give you a quick update. I've since changed keyboards from SwiftKey to Swipe. I had no problems composing any posts or replies on mobile Safari. It did not lock up or freeze. I was able to reply to several posts on the forums. I'm going to keep using mobile Safari for another day or two and see if anything happens.