Setting up Comcast email

Jason14

New Member
Bronze
Jul 16, 2007
44
1
0
#2
i do....
go to settings then mail then add account form there select other

ACCOUNT INFORMATION
Your name
and your camcast.net email address for address and for description
INCOMING MAIL SERVER
Host Name:mail.comcast.net
then your user name and password

OUTGOING MAIL SERVER (SMTP)
Host Name:smtp.caomcast.net
Username and passwprd optional
 

stevetim

New Member
Silver
Jul 20, 2007
606
0
0
#4
with Comcast, you might have to use port 25 on the smtp to get your emails through both wifi and edge. If you use just wifi, you don't need port 25. But to access Comcast's email server through edge it has to use port 25.

smtp.comcast.net:25 is the correct setting.

It's what I use and have used since day one.
 

todd1010

New Member
Bronze
Jul 15, 2007
34
0
0
#5
I have comcast email and I didn't set any port numbers and I've been receiving my email since day one perfectly.
 

stevetim

New Member
Silver
Jul 20, 2007
606
0
0
#6
I have comcast email and I didn't set any port numbers and I've been receiving my email since day one perfectly.
Ya, some people have luck with standards. I didn't. It may have to do with locale, and the server settings for different customers.
 

Donna GG

New Member
Aug 26, 2008
6
0
0
#8
can't send mail

can receive mail on my new iPhone, but get msg: "cannot send mail; sender's address is invalid." think using this Port 25 would fix that ... or?

Thanks for any help!



with Comcast, you might have to use port 25 on the smtp to get your emails through both wifi and edge. If you use just wifi, you don't need port 25. But to access Comcast's email server through edge it has to use port 25.

smtp.comcast.net:25 is the correct setting.

It's what I use and have used since day one.