Signal Issue

alamarco

Member
Bronze
Nov 28, 2008
162
8
18
Canada
myfigurecollection.net
#1
Is there anything I can do to fix my iPhone 3G signal? Just sitting in the same spot my signal is constantly going from full 3G to Edge, sometimes even hitting no signal.

I know the bars and symbols aren't being incorrectly stated as when browsing pages will load at normal 3G speeds and then start timing out or taking a minute to load.

It doesn't make sense to me because I'm not moving, the signal itself can't vary that much.

Couple weeks ago I had my iPhone replaced and the old one was fine, but just started having the issue a copule of days before sending it in. My new iPhone had these issues right from the get go.

I tried searching Google, but all I can find is topics relating to old iPhone firmware 1.1.3 or articles talking about a supposed firmware fix for iPhone 3G signal issues.

Any ideas?
 

drumthrasher109

New Member
Bronze
Jan 9, 2009
471
0
0
drumsplace.co.cc
#2
Maybe the spot you are sitting at just happens to not receive the full 3G signal?

I experienced the same stuff when I walked into a grocery store. My guess is that the 3G signal wasn't making its way to where I was in the building.
 

alamarco

Member
Bronze
Nov 28, 2008
162
8
18
Canada
myfigurecollection.net
#3
If it's not getting the signal fully, how am I able to get the signal for a minute, and then suddenly lose it?

Can you explain that? Is it just bursts of full signal? That wouldn't make sense though, because isn't the signal broadcasted at a uniform strength?

Thanks for the reply, looking forward for more :).
 

alamarco

Member
Bronze
Nov 28, 2008
162
8
18
Canada
myfigurecollection.net
#4
Test 1
Download: 1420 Kbps
Upload: 56 Kbps
Latency: 184 ms

Test 2
D: 400 Kbps
U: 54 Kbps
L: 228 ms

Test 3
D: 781 Kbps
U: 63 Kbps
L: 216 ms

Decided to look at a speedtest and sitting her at my desk it from 1400 Kbps to 400 Kbps to 800bps. At 1400 Kbps, that's not bad. It's 50% of 3G's full capacity. However 400 Kbps is only 13%! 800 Kbps is at least 27%, but still pretty bad. You can see the varying signal strength. How it drops a full 1 Mbps is pretty crazy.