Siri making springboard crash

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Kathie63

Member
Bronze
Mar 15, 2009
414
1
18
Wisconsin
#1
I must have installed something that made Siri not work. when I start Siri it makes beeping noises like it usually does but then the springboard crashes and goes into safe mode.

Anyone else having this problem?
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
700
113
#2
I must have installed something that made Siri not work. when I start Siri it makes beeping noises like it usually does but then the springboard crashes and goes into safe mode.

Anyone else having this problem?
What have you installed from Cydia recently? I recommend you install Crash Reporter from Cydia, it's a free .deb and it will create a crash file which sometimes can be helpful in trying to work out the reasons behind the actual crash i.e a list of suspects.
 
Jun 16, 2008
1,177
12
38
Tinley Park, IL
#5
Did you install any Siri tweaks? If you can, access mobile substrate options and shut off tweaks one at a time till you find the offender. If you don't know how/or have access to that, try accessing Siri in safe mode and see If she at least works there. Do you have a 4s or are you using Siri via spire on a 4 or 3GS?
 

Kathie63

Member
Bronze
Mar 15, 2009
414
1
18
Wisconsin
#6
Did you install any Siri tweaks? If you can, access mobile substrate options and shut off tweaks one at a time till you find the offender. If you don't know how/or have access to that, try accessing Siri in safe mode and see If she at least works there. Do you have a 4s or are you using Siri via spire on a 4 or 3GS?
I just tried safe mode and still crashes...tried shutting off tweaks one by one and turning back on one by one still crashes...I have 4s

I may have to restore to 5.1 and rejailbreak, there is an untethered jailbreak for 5.1 correct?
 

offroadhunter

Member
Silver
Apr 1, 2009
682
22
18
New York
#10
I just tried safe mode and still crashes...tried shutting off tweaks one by one and turning back on one by one still crashes...I have 4s

I may have to restore to 5.1 and rejailbreak, there is an untethered jailbreak for 5.1 correct?
Are you on 5.1? If your shsh blobs are saved on 5.0.1 then use redsn0w and restore as new and re-jb it, you don't need to upgrade to 5.1 if shsh is saved.
 

fijiman

Contributor
Silver
Feb 13, 2011
832
64
28
UK
#11
Are you on 5.1? If your shsh blobs are saved on 5.0.1 then use redsn0w and restore as new and re-jb it, you don't need to upgrade to 5.1 if shsh is saved.
Not going to happen if the OP has a 4s....:)
To the OP
Have you tried switching off Siri in settings and rebooting...?
 

fearofnormalcy

Evangelist
Gold
Jul 8, 2010
1,742
118
63
New Port Richey, FL
www.facebook.com
#12
Not going to happen if the OP has a 4s....:)
The OP does indeed have a 4S. (See post #6).

Just so everyone is clear, here's a direct quote from the pros at iPhone Dev Team:

  • Soon after 5.1 appears on Apple’s public servers (i.e. iTunes starts to offer it), Apple will stop signing 5.0.1 SHSH blobs.
  • If you have an iPhone4S, the basic rule above is really the only rule: you cannot restore back to 5.0.1 once the 5.0.1 signing window is closed, no matter what (even if you saved your SHSH blobs).
 

Kathie63

Member
Bronze
Mar 15, 2009
414
1
18
Wisconsin
#15
Did you install a cracked version of iFile?
No I got it directly from Cydia.

Also on my crash report it has primary suspect: lib apt-pkg.dylib.4.6.0
It says find package in cydia: APT 0.7 Stirct (lib) but when I try to remove it, it tells me if I do remove I may not be able to use Cydia and IOS? So I didn't remove it.
 

Kathie63

Member
Bronze
Mar 15, 2009
414
1
18
Wisconsin
#16
another problem! Now when I click ANYTHING it comes up:

Invalid operation
activator has called- [LAActivator registerListener:forName:]
improperly fromm outside SpringBoard.
Contact Activator's developer.

I am about ready to just update to 5.1! grrrrr
 

fijiman

Contributor
Silver
Feb 13, 2011
832
64
28
UK
#17
another problem! Now when I click ANYTHING it comes up:

Invalid operation
activator has called- [LAActivator registerListener:forName:]
improperly fromm outside SpringBoard.
Contact Activator's developer.


I am about ready to just update to 5.1! grrrrr
Have you tried to uninstall(temporarily) Activator..?
Remember there is no jailbreak for A5 devices on 5.1
It's worth keeping at it until you crack the problem.