SMS across both my idevices

Discussion in 'iOS Software' started by Rootntootn, Apr 6, 2013.

  1. Rootntootn

    Rootntootn Member
    Bronze

    Joined:
    Sep 11, 2011
    Likes Received:
    6
    Hi, I'm a doctor and use my iPhone5 and Ipad3 (both with latest ios6 versions) on call to receive SMS messages instead of pages.

    Both are registered under the same Apple ID, of course. I especially want that both receive each SMS I get because I chart responses using OpenOffice on my Ipad (Zagg case with included bluetooth keyboard--my mobile office). Under Setup/Messages I have my personal phone number at the top on both devices as the place both to receive and originate messages.

    Problem is, I get messages fine on my iPhone, but they don't come to my ipad always. The only way to get the messages consistently on the ipad is to resend them to myself from the iPhone. Then a copy shows up on both devices.

    Any guidance on why this is or how I could fix it that both receive all SMS to my phone number?

    Thanks!




    Sent using iCafe app
     
  2. Ohmster

    Ohmster Member
    Silver

    Joined:
    Jan 26, 2008
    Likes Received:
    20
    I've had a similar issue with iMessages across three devices (MBPr, iPad Mini, iP5). Only thing that has worked for me is turning off iMessages on the trailing device and then 'rebuilding' the account by re-enabling it. Right now, all three are behaving. Good luck.


    Sent using an iOS device
     
  3. Ohmster

    Ohmster Member
    Silver

    Joined:
    Jan 26, 2008
    Likes Received:
    20
    Is your Apple I'd account an enabled email in iMessage on both devices?


    Sent using an iOS device
     
  4. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,430
    If it's sent as an iMessage from an Apple device to your email, it will go to your iPhone and your iPad. If it's sent to your phone number as an SMS from a non-Apple device, it will only go to your phone. If it's sent to your phone number as an iMessage from an Apple device, it will only go to your phone.
     
  5. Ohmster

    Ohmster Member
    Silver

    Joined:
    Jan 26, 2008
    Likes Received:
    20
    That make sense, Europa. For some reason I thought I was getting all my messages across all devices (re your third point). Not sure now! :)

    Sometimes there is a lag or discontinuity until I use that device to send/respond.

    I do know that I can't seem to originate messages to non-iMessage accounts on the Mini.


    Sent using an iOS device
     
  6. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,236
    Just make sure your Answering Service staff has access to an iDevice. Task them with receiving your SMS messages and echoing them out to you as iMessages. Get your money's worth from those people.
     
  7. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,430
    It's not just an answering service; it would also be all of the nurses and doctors who call him directly. Since he can't control which phone they use, it's best to just stick with the iPhone as the iPad will only receive some of their messages.
     
  8. Rootntootn

    Rootntootn Member
    Bronze

    Joined:
    Sep 11, 2011
    Likes Received:
    6
    Both are enabled both for phone number and email. It's funny, after I disabled the imessaging on the ipad and the reenabled, the option to add new accounts wasn't present, but I got a message on iPhone that imessage had been reenabled on ipad both for phone number and email. hmm.
     
  9. Rootntootn

    Rootntootn Member
    Bronze

    Joined:
    Sep 11, 2011
    Likes Received:
    6
    Actually, nurses are supposed call staff doctors' answering service, so if I can get the answering service to text me using an idevice, I'll be good. Problem is, most of these services, including mine, have software running under windows to send messages to each doctor's account, to keep a record. --> no idevice there to text me with, sigh!
     
  10. Rootntootn

    Rootntootn Member
    Bronze

    Joined:
    Sep 11, 2011
    Likes Received:
    6
    that's it. gotta be an idevice on both ends
     
  11. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,236
    That's a security measure, to make sure you're aware of new devices that will be receiving your iMessages. It happens any time a new device becomes linked (or previously-linked device becomes re-linked) to your Apple ID for purposes of receiving iMessages.

    A notification also goes out to any OS X machines that you may have signed onto that same Apple ID:

    A6.jpg

    If I turn off iMessages on my iPhone and then turn it back on, OS X notifies me, as you can see above. In this example, it is informing me that my iPhone ("A6" is its name [Why?]) has just become available to receive iMessages at the three e-mail addresses I have previously chosen for iMessage reachability. It does not mention its phone number, even though I am able to receive iMessages addressed to my phone number, because OS X does not concern itself with phone numbers.

    This is just one example of the beauty of the Apple ecosystem.
     
  12. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,430
    Yeah, that does vary depending on the setting and doctor's preference. I work in an ICU and we typically call the MD's cell phone, but some prefer that we page, Airtouch or text message them. We have a list of the preferred method of contact next to each doctor's name.
     

Share This Page