SMS Time way off

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

xbprez

New Member
Nov 3, 2007
8
0
0
#1
Whenever I get txt messaged on my phone from someone, if they initiate the conversation there is a small time/date stamp at the beginning, however that time is off by about 4 hours from the time on my phone, even though they just messaged me.

However if I txt someone, the time stamp that shows is with the correct time. Any ideas why incoming sms messages are showing a timestamp of 4 hours old? Running 1.1.1 jailbroken and unlocked. (checked time/date settings, everything is set correctly, correct time shows on the phone).
 

Khris

New Member
Bronze
Oct 30, 2007
124
0
0
Edmonton, AB
#3
Other people who have jailbroken, and unlocked their iPhones have reported this as well. Seems to be an unfortunate byproduct of unlocking.
 

truehybridx

New Member
Bronze
Oct 31, 2007
40
0
0
#4
yes i have a problem like that, i think it kinda fixed itself however...

it use to take forever to get a txt back from my gf n then my iPhone would take its time sending a message too
 

csingh

New Member
Nov 22, 2007
1
0
0
#5
Whenever I get txt messaged on my phone from someone, if they initiate the conversation there is a small time/date stamp at the beginning, however that time is off by about 4 hours from the time on my phone, even though they just messaged me.

However if I txt someone, the time stamp that shows is with the correct time. Any ideas why incoming sms messages are showing a timestamp of 4 hours old? Running 1.1.1 jailbroken and unlocked. (checked time/date settings, everything is set correctly, correct time shows on the phone).

same deal here...anyone find a solution? biggest annoyance ever
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#6
ive had this problem with Tmobile in general, not just the iPhone...on my last two phones, every once in a while the SMS time would be CST even though im in EST...it was weird...it did seem to fix it self.
 
Nov 6, 2007
14
0
0
#7
I also had this problem but i searched online and found a way to fix this. Basically u have to set your phone to a place with no DST and GMT +0. Examples are Burkina Faso, Bouvet Island, Greenland, or Rabat, Morroco. I used Rabat, Morroco. So u turn off automatic update... choose Morocco as the time zone and manually set the correct time. This should work for now.

Settings > General > Date and Time

Set Automatically = OFF
Time Zone = Rabat, Morocco
Set Date & Time = Manually
Calendar Time Zone Support = OFF
 
Sep 29, 2007
348
0
16
#8
I think I know the reason. I don't think there is anything wrong its just that when there is a big gap in between sending messages it tells the time the new one was sent.

For example if I send a message at 2:00am and I talk to that person for awhile for that hour and they send me 20 messages, notice how no time stamp will come after it.

Then say you go somewhere and you get a message from that same person 1 hour-2 hours later, notice the time stamp?

This is what I have noticed and is my only way I am able to explain it.