Software too old?

mcquaid1

Member
Bronze
Dec 8, 2007
134
0
16
Ireland
#1
i just got myself an imac G5 and i tried plugging in my iPhone, it says it cant sync because it needs software 10.4 or later.....ahhh......what do i do now?
 

mcquaid1

Member
Bronze
Dec 8, 2007
134
0
16
Ireland
#3
how do i upgrade? do i have to buy new software? or is there an easier way?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,385
1,089
113
DC
#4
as long as you meet the minimum system requirements, you can upgrade to Tiger (10.4.x) or Leopard(10.5.x). Apple only sells leopard now, but tiger is still available off of ebay, and maybe even Amazon.
 

mcquaid1

Member
Bronze
Dec 8, 2007
134
0
16
Ireland
#5
ok thanks.....now i hace an imac G4 with version 10.4.9 and my G5 with 10.3? how did my g4 update work and my g5 wont? is there a way to change software from g4 to g5? i know...its a long shot but what the hell.....
 

geordisjd

Zealot
Bronze
Jul 1, 2007
2,442
12
38
#6
ok thanks.....now i hace an imac G4 with version 10.4.9 and my G5 with 10.3? how did my g4 update work and my g5 wont? is there a way to change software from g4 to g5? i know...its a long shot but what the hell.....
You can't "upgrade" Mac Os 10.3 (Panther) to Mac Os 10.4 (Tiger). They are different OS's. You need to get a new install disk for Tiger (as in "buy it") and install it on your G5, then you can upgrade to 10.4.9 through software update.