Starbucks Free WiFi problem

Aug 3, 2007
5
0
0
#1
For about a week I was able to take advantage of the free wifi from Starbucks/ATT, but I upgraded to the 3G a couple of days ago, and with the new phone I don't appear to have access to the free Starbucks wifi any longer. When I connect to att wifi, the browser takes me to a different sign-in screen than before. This one doesn't ask for my phone number so that it can send me a text. Rather, it provides me a number of login choices, all of which appear to be paid, and none of which are the complementary service I was able to get just a couple of days ago.

Any thoughts?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#2
Clear your Cookies and cache and try again. I wasn't able to login the first time for some reason, but was able to get on fine the second time I tried.
 
Aug 3, 2007
5
0
0
#3
Thanks, but it didn't work

Thanks Hawk, but clearing the cache and cookies didn't work. I get to a screen from ATT wifi that has the following choices:
Use membership
Purchase One-Time Connection
Purchase Membership
Purchase Multiple Sessions
Use a Coupon
Use Prepaid Card

Then below that it has a user login and password screen.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#4
Thanks Hawk, but clearing the cache and cookies didn't work. I get to a screen from ATT wifi that has the following choices:
Use membership
Purchase One-Time Connection
Purchase Membership
Purchase Multiple Sessions
Use a Coupon
Use Prepaid Card

Then below that it has a user login and password screen.
Well, that might their fault at that location then. Their router might not be updated to properly redirect iPhone traffic. I am sure that there has got to be another starbucks around you can test at- or a McDonalds, as they are part of that network too.
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#5
starbucks next door. I haven't tried this yet so I'll stroll over and see if it works... I'll update in ten minutes...

Hmmm... Starbucks wifi is a no-go for me. It shows up on the iPhone as connected but the little spinning wheel churns away trying to load a page. It never does. This starbucks even has a sticker on the window that says "free wifi" yet I can't even get an initial sign in page. Cleared cache cookies and history. I'm on a jailbroken 2.1 3g and can sign on to numerous other wifi locations whenever I want.

Starbucks is such a trendy over priced bunch of bullshit anyway..
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#6
I actually tried the official free WiFi on Tuesday and it worked without a problem. Actually, I did notice that it had a tendency to log me out if I locked the screen for even a few seconds or if I closed Safari and opened say SMS.

It could be the location just not being fully prepared yet.
 

claygreenberg

New Member
Bronze
Oct 3, 2008
35
0
0
#8
AT&T has to have each iPhone number properly provisioned foe the wifi network, and some of them have not been. I had problems with the free wifi at first, then I called AT&T wifi (NOT AT&T wireless) and they fixed it within just a couple of minutes. Everything works correctly now. I believe the number is 800-866-7520 but try 7250 also if it doesn't work.
 

the_monitor

New Member
Bronze
Sep 30, 2008
101
0
0
MA
#9
Good info! I like it when someone has an easy fix.
 

iksn

Member
Silver
Aug 7, 2008
717
16
18
Near Las Vegas
#10
I actually tried the official free WiFi on Tuesday and it worked without a problem. Actually, I did notice that it had a tendency to log me out if I locked the screen for even a few seconds or if I closed Safari and opened say SMS.

It could be the location just not being fully prepared yet.
This is the big problem with this service. As soon as you disconnect, it makes you put your phone number in again, and wait for a new text message to log on. It will do this continually everytime you disconnect, which is very easy to do.
This totally sucks, you're better off just sticking with 3G. I learned this the pain in the butt, hard way.
 

jsntrenkler

Zealot
Silver
Sep 22, 2008
942
3
38
Tucson Arizona
#12
At my local starbucks 3G is solid, however the free wifi works well. Login, enter phone number, click on the text message and voila ... I have had no issues.
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#13
This is the big problem with this service. As soon as you disconnect, it makes you put your phone number in again, and wait for a new text message to log on. It will do this continually everytime you disconnect, which is very easy to do.
This totally sucks, you're better off just sticking with 3G. I learned this the pain in the butt, hard way.
After disconnecting twice in a matter of minutes I decided to just try clicking on the link in the first text I received and it connected me to WiFi. I'm not sure if it was a coincidence but at least that will save the time of putting in the phone number and waiting for a text each time.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#14
After disconnecting twice in a matter of minutes I decided to just try clicking on the link in the first text I received and it connected me to WiFi. I'm not sure if it was a coincidence but at least that will save the time of putting in the phone number and waiting for a text each time.
Yes, the initial text link is good for 24 hours, and then it will not work anymore, so you don't have to keep logging in fresh.
 

dnvl

New Member
Feb 2, 2009
3
0
0
#15
I am having the same issue as the original poster. My iPhone 3G gets the weird, non-iphone-centric screen with the bunch of "use membership", etc. type links.

What's worse is that my fiancee's phone, which is on the same plan as mine except hers is not 3G, works fine! Side-by-side, my phone does not work and hers does. Any suggestions?

I'm going crazy trying to figure it out and so far AT&T has no idea what's wrong (and won't admit anything is wrong). They say the number is provisioned for WiFi usage so I might be having a different issue than what was proposed as a solution earlier.
 

sim

New Member
Aug 19, 2008
58
0
0
Rochester, MN
#16
I am having the same issue as the original poster. My iPhone 3G gets the weird, non-iphone-centric screen with the bunch of "use membership", etc. type links.

What's worse is that my fiancee's phone, which is on the same plan as mine except hers is not 3G, works fine! Side-by-side, my phone does not work and hers does. Any suggestions?

I'm going crazy trying to figure it out and so far AT&T has no idea what's wrong (and won't admit anything is wrong). They say the number is provisioned for WiFi usage so I might be having a different issue than what was proposed as a solution earlier.
Can you look at her phone and type the URL for the iPhone specific page from her phone into your phone?

Steve
 

dnvl

New Member
Feb 2, 2009
3
0
0
#19
Can you look at her phone and type the URL for the iPhone specific page from her phone into your phone?

Steve
I'll try this the next time we are both at a Starbucks and report back. Anyway, I've been on the phone with AT&T support (both WiFi and mobile) and apparently this is a known issue and they're taking their time fixing this one-by-one (or in batches).

The tech couldn't exactly tell me what the issue is, but the point is that I'm screwed until it's actually fixed (which could take a while, he couldn't give me an ETA). Has anyone else encountered this issue?

UGH.
 

articwolf

New Member
Apr 18, 2009
1
0
0
#20
Login screen

I have the same problem with the wrong login screen and it demanding a membership. I have tried to get the free wifi at multiple Starbucks in the area with two iPhone 3Gs and the correct login screen will not appear. If you do get the URL please post it because the customer help is no help at all.