STILL getting SENT mail with GMAIL!

Aug 16, 2007
24
0
0
#1
No matter what I do, filter, put it as me or my full name, no BBC, CC, etc. I've searched the forums! Everyone has 100 different ways to get rid of receiving your sent mail on your iPhone but none have worked for me. What is the simple true solution?
 

petalmom

New Member
Silver
Jun 30, 2007
494
0
0
#2
Try this.

Log into your g-mail account, go to settings, go to forwarding and pop, under forwarding click on "disable forwarding", under pop download option 2 when messages are accessed with pop, select "delete gmails copy"

This will also send any messgae that you send from your g-mail account directly to the trash rather than your sent mail but you can pull it out of there if you feel you need to keep it.

This works for me, good luck!
 

thesaint

New Member
Bronze
Jul 9, 2007
341
0
0
DFW
#3
You can as well solve this problem by creating a new POP account for Gmail. Delete the default account settings for Gmail on iPhone and create a new one. This worked for me.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
48
ATL
#4
Me too. I stopped using the Gmail Template that the phone already has, and setup the account as POP instead. Works like a charm.
 

thesaint

New Member
Bronze
Jul 9, 2007
341
0
0
DFW
#5
This is just an update to my previous mail. I apologize if this a repeat.

The mails I received on Gmail were not being deleted, even when the "Delete message - When deleted from the inbox" was selected on the iPhone. I went back to my account and selected "Delete Gmails copy" and now as soon as I access the mails using the POP service, the mails on the Gmail are getting deleted.

I don't see a reason as to why we need to stick to the Gmail template on iPhone.
 

Gray

New Member
Bronze
Aug 19, 2007
41
0
0
#6
lol.
I just deleted my Entire gmail archive. :p
 

Dawgfan

Member
Bronze
Jul 27, 2007
347
0
16
Atlanta, GA
#7
..not sure if this has been mentioned....

Just go into your Gmail account and create a rule that says if you receive email from THE GMAIL ADDRESS you are in, then delete it or do whatever you want with it except send it to the inbox/iPhone..
 

sas1

New Member
Aug 8, 2007
13
0
1
#8
You have to go into the account settings then click on advance. Once you are in the adance tab turn recent mode off.
 

mogz

New Member
Bronze
Jun 27, 2007
116
0
0
SF
#9
You can as well solve this problem by creating a new POP account for Gmail. Delete the default account settings for Gmail on iPhone and create a new one. This worked for me.
Works for me!

Thanks.
 

PhilipJohn

New Member
Bronze
Aug 24, 2007
163
0
0
Bronx, New York
#10
Well my problem is it seems I can only check my email once from the mail application, the next time I check the same e mail it gives me an error message saying the mail has not been downloaded from the server. And if it's an important e mail I have to go through safri to re read it. And could someone be willing to put a step by step of how to set up gmail under other on setting it up as pop, I don't know exactly what to put in all the fields since I am so new to all of this. Thanks!
 

SingleDouble

New Member
Bronze
Jul 13, 2007
40
0
0
#11
..not sure if this has been mentioned....

Just go into your Gmail account and create a rule that says if you receive email from THE GMAIL ADDRESS you are in, then delete it or do whatever you want with it except send it to the inbox/iPhone..
yes, but what if you want to centralize/backup your mail through gmail. I'm pop retrieving from different sources and want Gmail to be the master backup.

Does anyone know how to get rid of this self-sending thing another way?
 

ps49556n

New Member
Silver
Jun 21, 2007
545
1
0
NYC
#12
No matter what I do, filter, put it as me or my full name, no BBC, CC, etc. I've searched the forums! Everyone has 100 different ways to get rid of receiving your sent mail on your iPhone but none have worked for me. What is the simple true solution?


Same thing for me, this is by FAR the most annoying problem I have with iPhone....
 

Dawgfan

Member
Bronze
Jul 27, 2007
347
0
16
Atlanta, GA
#13
yes, but what if you want to centralize/backup your mail through gmail. I'm pop retrieving from different sources and want Gmail to be the master backup.

Does anyone know how to get rid of this self-sending thing another way?
I am not getting what is so hard. ALL of my email goes through Gmail and I get it via POP (setting up the account on my iPhone). I get my mail, in fact I just got a receipt from the Apple Store before I could get out the door without polling.

If you go into your Gmail account and create the rule that says...delete/trash any email coming from yourself (the Gmail address you are logged into) you will not have this problem.

It may not sync perfectly but if you want that you may be better off with a Blackberry. I just came from a BB to the iPhone and while email works for me..it is FAAAAAR from as good as with the BB.. But we KNOW this.

good luck.
 

PhilipJohn

New Member
Bronze
Aug 24, 2007
163
0
0
Bronx, New York
#14
I am not getting what is so hard. ALL of my email goes through Gmail and I get it via POP (setting up the account on my iPhone). I get my mail, in fact I just got a receipt from the Apple Store before I could get out the door without polling.

If you go into your Gmail account and create the rule that says...delete/trash any email coming from yourself (the Gmail address you are logged into) you will not have this problem.

It may not sync perfectly but if you want that you may be better off with a Blackberry. I just came from a BB to the iPhone and while email works for me..it is FAAAAAR from as good as with the BB.. But we KNOW this.

good luck.
Where is the setting to create this rule?
 

Dawgfan

Member
Bronze
Jul 27, 2007
347
0
16
Atlanta, GA
#15
Where is the setting to create this rule?
I know it is in one of the settings tab. You basically want to add a rule that says if you receive an email with a From address of (insert your Gmail address here) then just delete it...

Unless you can think of a situationw where you want to get an email from the VERY email address you are using to send with....
 

UGActg

New Member
Sep 8, 2007
18
0
0
#17
From https://mail.google.com/support/bin/answer.py?answer=72454 on setting up Gmail on your iPhone...

In the User Name field, enter 'recent:' followed by your full username (recent:username@your_domain.com). This will enable POP Recent mode, which will give you a better experience on the iPhone.
f you notice that messages you send from your iPhone are appearing in your iPhone's inbox, please note that this POP behavior is a result of enabling Recent mode to ensure that all other POP clients will be able to access your messages. We're aware of this issue and thank you for your patience while we address this issue.
So in the meantime just do what the other people said about adding a new account.