Strange keyboard behavior entering login

dcom

Zealot
Gold
Aug 7, 2007
1,421
3
38
Suwanee, GA
#1
Not here, but on Twitter.

If I use the iPhone to log in to my Twitter account, via Safari, I don't see the letter 's' pop up off the keyboard when I tap it in the User ID or Password field. All the other letters seem to work just fine, but the 's' doesn't. If I tap the uppercase (up-arrow) to type an uppercase 'S', I see the S but any attempt to tap a lowercase 's' won't produced the popup. It enters the s in the input field as it should though, which is odd. If I hold down the 's', I get the other variations in a popup but never the single 's'.

Has anyone else seen this behavior on other fields or know what what might cause it? My phone isn't jailbroken but it was previously. I also tried it with my wife's stock iPhone, which has never been jb'd and it had the same behavior
 

geek_riot

New Member
Nov 2, 2008
3
0
0
#2
I have that problem. For me it will be a random letter that won't pop up for the duration of my browsing session.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#3
I see what you're saying, Drew. I tried typing "suburbanhaikuist" in this reply box on my iPhone and could not type the last "s"

This is part of the iPhone's autocorrect system. It will scan the word your typing and remove letters that it considers "improbable" for you to actually want. Unfortunately, I don't know of any way around this other than to type the wrong letter, backup, then hit the one you want.
 

dcom

Zealot
Gold
Aug 7, 2007
1,421
3
38
Suwanee, GA
#4
I see what you're saying, Drew. I tried typing "suburbanhaikuist" in this reply box on my iPhone and could not type the last "s"

This is part of the iPhone's autocorrect system. It will scan the word your typing and remove letters that it considers "improbable" for you to actually want. Unfortunately, I don't know of any way around this other than to type the wrong letter, backup, then hit the one you want.
I know what you're talking about but this isn't the same problem. It's not that the phone won't let me type the letter, it's that the letter's "bubble" won't pop up on the keyboard. The letter actually appears in the input field, though.

If you go to twitter.com (mobile version will show the problem) and try typing in 'psylichon' in the login field, tell me if the 's' bubble pops up when you tap it on the keyboard.
 

dcom

Zealot
Gold
Aug 7, 2007
1,421
3
38
Suwanee, GA
#5
Update...Dave, I think you're right about the auto-correction. I turned it off in Settings->Keyboard and things worked. Not sure I want to leave it off though, I like the help it gives. :)

Thanks for pointing me in the right direction though.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#6
One thing you could try (I don't know if it will work), is typing your handle 5 or 6 times in a row using the Notes application. I know this works with cancelling autocorrect "suggestions" by basically adding the word to the libarary, but I'm not sure if it works with the "key exclusions" or whatever you want to call this phenomenon. Worth a shot.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#7
Not here, but on Twitter.

If I use the iPhone to log in to my Twitter account, via Safari, I don't see the letter 's' pop up off the keyboard when I tap it in the User ID or Password field. All the other letters seem to work just fine, but the 's' doesn't. If I tap the uppercase (up-arrow) to type an uppercase 'S', I see the S but any attempt to tap a lowercase 's' won't produced the popup. It enters the s in the input field as it should though, which is odd. If I hold down the 's', I get the other variations in a popup but never the single 's'.

Has anyone else seen this behavior on other fields or know what what might cause it? My phone isn't jailbroken but it was previously. I also tried it with my wife's stock iPhone, which has never been jb'd and it had the same behavior
I just recently started having the same problem with the letter d. It is very random though. It works most times, but occasionally it will go through a period of not popping up-then it will work for a long time again.
 

dcom

Zealot
Gold
Aug 7, 2007
1,421
3
38
Suwanee, GA
#8
I just recently started having the same problem with the letter d. It is very random though. It works most times, but occasionally it will go through a period of not popping up-then it will work for a long time again.
It does seem to be random. I tried typing in another word that didn't start with 's' and it almost seems like the letter I type in first is the one that has the problem.

I reported it to Apple and will also report it to Twitter. I've had other input fields that exhibit other problems but it seems like there must be some property of the field that tells the iPhone keyboard to use Auto-correction. For instance, on this board, my user ID is 'dcom' and if I log in using the iPhone, I can successfuly enter 'dcom' without needing to correct it. However, on most other user ID fields, if I start typing 'dcom', the auto-correction forces me to type 'dcon' and I have to backspace the n and type m. That tells me there's something about the website or input field that affects the iPhone auto-correct feature.
 
Jul 6, 2007
1,832
7
38
26
Marietta, GA
about.me
#9
I have this problem too, but not with any specific letter. The letters show in the text field just fine, but the keys don't pop up. This happens randomly but when it does none of the letters pop up until i exit the app and go in again.
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#10
I have this problem too, but not with any specific letter. The letters show in the text field just fine, but the keys don't pop up. This happens randomly but when it does none of the letters pop up until i exit the app and go in again.
I have the exact same problem. It doesn't really bother me though... I actually kind of like it.
 

Pimpboy51

New Member
Bronze
Sep 18, 2007
456
0
0
25
Orlando, Florida
#11
Sounds like the 2.2.1 firmware is what started this madness. I don't think I've had this issue YET lol. I type too fast to even see what I am typing haha
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#13
Sounds like the 2.2.1 firmware is what started this madness. I don't think I've had this issue YET lol. I type too fast to even see what I am typing haha
I've noticed this on 2.2 and on 2.2.1 I notice it occasionally.
 

dcom

Zealot
Gold
Aug 7, 2007
1,421
3
38
Suwanee, GA
#14
It appears to be related to the Auto-correct feature. When I turn that off from Settings->General->Keyboard, the problem goes away, but so does Auto-correct. Turn it back on and the problem comes back.

Upon further testing, it seems that it only happens if Auto-correct AND Auto-capitalization are on. If I turn either one off, the problem doesn't show up.