Stuck at Apple logo?

Kaitlyn2004

New Member
Bronze
Aug 6, 2008
72
0
0
#1
I installed winterboard, made the change to thew wallpaper.. it changed, then randomly it went to the Apple logo and is "stuck" there now.

I held power+home to reset it, it turned off and on and is again stuck at the Apple logo... won't go past it!
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#2
This is a rather common issue. Apparently, a common fix is (was?) replacing the M68AP.plist - in this case, it is corrupt. I'm not sure if the file still exists in the 2.0 + firmwares, but it's worth a shot. The file is located here:

/System/Library/CoreServices/SpringBoard.app/

If you had SSH installed and turned on before the problem, you can SSH in via any FTP client. Navigate to the above path and replace the existing one with this one.
 
Last edited by a moderator:
Sep 15, 2008
1
0
0
#3
you might need to do a restore.. i had too... same thing last night
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
25
Boston
#4
This is a rather common issue. Apparently, a common fix is (was?) replacing the M68AP.plist - in this case, it is corrupt. I'm not sure if the file still exists in the 2.0 + firmwares, but it's worth a shot. The file is located here:

/System/Library/CoreServices/SpringBoard.app/

If you had SSH installed and turned on before the problem, you can SSH in via any FTP client. Navigate to the above path and replace the existing one with this one.
No, sir.

I feel as though i am simply contradicting you today.

Give me a link which says that the M68AP.plist file does that.


the M68AP.plist file - if it was corrupted - you would boot, but your phone would think its an iPod touch, you would have no icons on the springboard, and you would not be able to access anything except the music player.

not even videos.


i am quite familiar with this plist and what it does.
 
Last edited by a moderator:

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#5
It seemed to work quite fine in this thread. It also worked fine for me when I did it a few months back.
 
Last edited by a moderator:

LionOfTheSouthUK

New Member
Bronze
Jul 23, 2008
82
1
0
#6
What about this? I found this before the 2.1 upgrade, when downloading something from Cydia would end up with me having to restore.

1. turn iPhone off
2. connect cable
3. turn on ipod iPhone
4. listen for ding dong (window) or what ever the mac sound is
5. ssh to your ipod iPhone
6. goto /var/mobile/
7. rename Applications to Applications2
8. wait 5 second and your springboard will pop up
9. now rename Applications back and restart

DO NOT FREAK IF YOU SEE SOME APPS ARE MISSING
If this happens a manual sync in iTunes WILL BRING BACK YOUR APPS,IN NORMAL STATE, because the apps are still downloaded on your device, Just not Visible.


Whether thats only fixes the Cydia problem I have no idea, but I assume it cannot hurt to try if it looks like a restore is on the cards.
 

peteostro

New Member
Nov 13, 2008
1
0
1
#7
What about this? I found this before the 2.1 upgrade, when downloading something from Cydia would end up with me having to restore.

1. turn iPhone off
2. connect cable
3. turn on ipod iPhone
4. listen for ding dong (window) or what ever the mac sound is
5. ssh to your ipod iPhone
6. goto /var/mobile/
7. rename Applications to Applications2
8. wait 5 second and your springboard will pop up
9. now rename Applications back and restart

DO NOT FREAK IF YOU SEE SOME APPS ARE MISSING
If this happens a manual sync in iTunes WILL BRING BACK YOUR APPS,IN NORMAL STATE, because the apps are still downloaded on your device, Just not Visible.


Whether thats only fixes the Cydia problem I have no idea, but I assume it cannot hurt to try if it looks like a restore is on the cards.
Hey you saved my ass! I just did in installer update and it F'ed my iPhone. Was stuck at the Apple screen. Did what you said and im back in businesss

Thanks!