suggestions needed..

Feb 24, 2008
8
0
0
#1
I bought a jailbroken iPhone with firmware 1.1.2 (using it with other sim carrier) with installer.app 3.04b,BSD Subsystem 2.0 & iworld 1.0 already installed on my iPhone...all the basic features of the phone working very well but i want to have the isms,locate me,custom icons & other 3rd party applications..

So,guys please suggest me that whether i should upgrade my firmware.If yes,then please suggest safe guide links so that i can use other sim carrier safely on my iPhone..

And,if i can have all the features without the need of upgradation...then,also please provide the guide links..

And,one more thing...will my applications like isms would work if i am not connected to internet..

Your quick reply would be highly appreciated.

Cheers !
 

OJsakila

New Member
Jul 15, 2007
3,021
1
0
Jupiter's sulphur mines
#2
1.1.2 is a good firmware. I found it largely stable and highly modeable. Until you have become extremely familiar with this site AND your new phone, I would NOT upgrade. However, you shouldn't have too much of a problem adding programs from installer. If any trouble does arise, you can always restore and rejailbrake and reunlock. But it will be hell for you if you don't know what you're doing. But it CAN be done if if you search around a bit you might learn something.

Wouldn't it have been cheaper to buy a new iPhone and unlock it yourself? If you answer that you don't know how to that and that's why you got an unlocked one, well then, that's why I forewarn you about messing around with upgrades and such right now.... If you felt you had to buy it already unlocked from some numb nuts that spent about ten minutes unlocking it, then I'd be weary of screwing up..!
 
Feb 24, 2008
8
0
0
#3
well,thank you for your suggestions & i have done some seraching in the internet but i heard some conflicting reports about 1.1.3 official upgrader update directly from the iPhone...

do you recommend it....
 

Bone

Zealot
Gold
Feb 11, 2008
1,214
2
38
#4
I would definatly recommend it! I have loved 1.1.3 since it came out. There are a few bugs in it but for me personall, very much worth it.

Oj isdefinatly right tho, you need to do your reserch first.
sorry I can't typ today. LOL
 
Feb 24, 2008
8
0
0
#5
thank you...but now,i am trying to install the package..it says error....package download failed ...this is because that i am using a non AT & T carrier....?
 

Bone

Zealot
Gold
Feb 11, 2008
1,214
2
38
#6
look for bsd subsystem in your installer. This need to be installed first. Also when u try to make your next install look to see if it asks you to clear qued? If so clear it.