Summerboard 1.1.1

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

sr4482

New Member
Oct 9, 2007
27
0
0
#1
I followed the instructions on the summerboard site, but it still doesn't work properly. It shows the icon on the screen; however, it freezes for a couple seconds then reverts back to the springboard.

ANy suggestions?
 

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#2
I followed the instructions on the summerboard site, but it still doesn't work properly. It shows the icon on the screen; however, it freezes for a couple seconds then reverts back to the springboard.

ANy suggestions?
Did you change its permissions to 0755 in WinSCP or the like?
 
Aug 9, 2007
178
2
18
#3
Can someone do a "Dummy's guide" for this

I read the manual install instructions, but I was unsure where to copy most of the files. Most of the folders it specified did not exist and I was unsure where or if to just create them. :sick:
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#4
I read the manual install instructions, but I was unsure where to copy most of the files. Most of the folders it specified did not exist and I was unsure where or if to just create them. :sick:

For SummerBoard.framework and SMBPrefs.app, just drag those folders to their respective locations. For Themes, yes...you'll have to create a new directory in
/var/root/Library/ called SummerBoard, then a subdirectory called Themes.

Remember to set all plists permissions to 0755.

 

sr4482

New Member
Oct 9, 2007
27
0
0
#5
For SummerBoard.framework and SMBPrefs.app, just drag those folders to their respective locations. For Themes, yes...you'll have to create a new directory in
/var/root/Library/ called SummerBoard, then a subdirectory called Themes.

Remember to set all plists permissions to 0755.

When you drag Summerboard.framwork and SMBPrefs.app are you replacing the folders already there or just placing them into the folders that are there (there are already summerboard.framework and smbprefs.app folders).
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#6
When you drag Summerboard.framwork and SMBPrefs.app are you replacing the folders already there or just placing them into the folders that are there (there are already summerboard.framework and smbprefs.app folders).
Summerboard.framework and SMSPrefs.app should not be there yet, unless you are attempting another manual install. If so, just replace over the old Summerboard.framework and SMSPrefs.app folders.
 

sr4482

New Member
Oct 9, 2007
27
0
0
#7
Summerboard.framework and SMSPrefs.app should not be there yet, unless you are attempting another manual install. If so, just replace over the old Summerboard.framework and SMSPrefs.app folders.

Ok...I did everything it said to do and still can't get it to come up. The icon is on my spring board and when I click on summerboard, it tries to come up then crashes back to the spring board. Anyone suggestions?
 
Aug 9, 2007
178
2
18
#8
permissions

For SummerBoard.framework and SMBPrefs.app, just drag those folders to their respective locations. For Themes, yes...you'll have to create a new directory in
/var/root/Library/ called SummerBoard, then a subdirectory called Themes.

Remember to set all plists permissions to 0755.

how do you set plist permissions ?
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#9
Ok...I did everything it said to do and still can't get it to come up. The icon is on my spring board and when I click on summerboard, it tries to come up then crashes back to the spring board. Anyone suggestions?
Try starting up Summerboard a few times. It crashed on me about 3 times before it finally opened up. Now it seems to work flawlessly.
 

sr4482

New Member
Oct 9, 2007
27
0
0
#13
OK...really not sure what's wrong with Summerboard.

I redid it over 4 times and it still won't come up. It keeps trying to activate...then crashes. I did it exactly like the directions said to do and i did change it to 0755.

Anyone else continually havnig this issue?
 

up10ad

Genius
Gold
Aug 1, 2007
3,606
468
83
Fruita , CO
up10ad.com
#15
Hmmmm, Summerboard is working fine but the SMBPrefs app presents just a gray screen, then goes away after about 30 secs. I have set all .plist files to 0755. Is the SMBPreff app functional yet?
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#17
The only other thing I can suggest is to set 0755 permission to ALL files within SMBPrefs.app and Summerboard.framework. After setting these permissions, restart the iPhone.

To amalone87: com.apple.SpringBoard.plist goes into:
/System/Library/LaunchDaemons/com.apple.SpringBoard.plist

Also, please note: this Alpha Summerboard is for 1.1.1 jailbroken phones/ipod touches only.
 

sr4482

New Member
Oct 9, 2007
27
0
0
#18
Enigmanic

The only other thing I can suggest is to set 0755 permission to ALL files within SMBPrefs.app and Summerboard.framework. After setting these permissions, restart the iPhone.

To amalone87: com.apple.SpringBoard.plist goes into:
/System/Library/LaunchDaemons/com.apple.SpringBoard.plist

Also, please note: this Alpha Summerboard is for 1.1.1 jailbroken phones/ipod touches only.

Enigmanic,

Under system/library/launchdaemons i see a com.apple.springboard.plist file. Do I replace that file or just add another folder with the new com.apple.springboard.plist file?
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#19
Enigmanic,

Under system/library/launchdaemons i see a com.apple.springboard.plist file. Do I replace that file or just add another folder with the new com.apple.springboard.plist file?
You replace the existing file. And remember set octal permissions to 0755.
Did you get my private message I sent you? Let me know if you need any help....