Summerboard/Installer issue

iMerlin

New Member
Silver
Sep 20, 2007
662
0
0
Algonquin, IL
#1
Hey all, I searched and didn't find anyone having this issue.
I have a modded 1.1.1 phone with Installer 3.0 loaded. I have the new Summerboard running. It's a little buggy but it works. However, half of the themes on Installer wont download for me. All of the themes that say "Install requires Summerboard" wont load. They unpack, then say Summerboard is needed. But I have Summerboard installed so what is the deal? Are these themes only for the old Summerboard?
 

Griffinaz

Zealot
Gold
Oct 5, 2007
1,046
13
38
Phoenix, Arizona
#2
Hey all, I searched and didn't find anyone having this issue.
I have a modded 1.1.1 phone with Installer 3.0 loaded. I have the new Summerboard running. It's a little buggy but it works. However, half of the themes on Installer wont download for me. All of the themes that say "Install requires Summerboard" wont load. They unpack, then say Summerboard is needed. But I have Summerboard installed so what is the deal? Are these themes only for the old Summerboard?
I have not run across this happening but just a question, did you do a full restart after installing Summerboard? That is the first thing I would do. Hold the button until the red restart bar shows, let it power off and then back on and try it again. Other than that I am lost.
 

mittenman

Member
Silver
Jul 25, 2007
813
0
16
Nowhere, Mitten
#3
I was having the same problem when I first broke in on 1.1.1 It only seemed to be an issue with the themes that were included in the source file I got from Tinman in his "easy guide one-click" thing-a-ma-bob. I never got into figuring it out though, have had to restore too many times and don't mess with that source file no mo'.
 

enigmanic

New Member
Silver
Jun 27, 2007
513
0
0
#4
Hey all, I searched and didn't find anyone having this issue.
I have a modded 1.1.1 phone with Installer 3.0 loaded. I have the new Summerboard running. It's a little buggy but it works. However, half of the themes on Installer wont download for me. All of the themes that say "Install requires Summerboard" wont load. They unpack, then say Summerboard is needed. But I have Summerboard installed so what is the deal? Are these themes only for the old Summerboard?
That's because you've either installed Summerboard manually or via iBrickr. Because of this, Installer thinks you don't have Summerboard installed. An easy solution is to uninstall Summerboard and then reinstall again via Installer (make sure you choose the new version of Summerboard, which is currently 3.0a11).

Actually, I'm pretty sure you don't even need to uninstall Summerboard first....you can just install right over it and you'll be fine.
 

Stevonw

New Member
Silver
Sep 14, 2007
560
0
0
UK
#5
I see that when i removed the new summerboard it gave me a warning that when i removed it that i may not be able to launch 3rd party apps.

This however was not the case and i no longer have a use for Summerboard (i manually mod my icon's as it saves crashes/slowing down). I upgraded/jailbroke/patched springboard with the 1 click iFuntastic method.

Hopefully this can help others in some way :(
 

iMerlin

New Member
Silver
Sep 20, 2007
662
0
0
Algonquin, IL
#6
I have not run across this happening but just a question, did you do a full restart after installing Summerboard? That is the first thing I would do. Hold the button until the red restart bar shows, let it power off and then back on and try it again. Other than that I am lost.
Yeah bro, Ive tried a couple of reboots and even restarts.

That's because you've either installed Summerboard manually or via iBrickr. Because of this, Installer thinks you don't have Summerboard installed. An easy solution is to uninstall Summerboard and then reinstall again via Installer (make sure you choose the new version of Summerboard, which is currently 3.0a11).

Actually, I'm pretty sure you don't even need to uninstall Summerboard first....you can just install right over it and you'll be fine.
I actually did install SMB from iBrickr the first time. But once Installer updated to 3.0, and SMB 3.0a11 was on Installer. I removed the manually installed SMB, updated INstaller and then loaded SMB 3.0a11 from the new Installer. Before I did this, Installer had 2 versions of SMB on it, the Old Summerboard and the Summerboard Alpha 3.0a11. I loaded 3.0a11 and now only the old appears in the Installer. 3.0a11 is listed under the uninstall section. So there isn't anything there to load except the old version.
 

iMerlin

New Member
Silver
Sep 20, 2007
662
0
0
Algonquin, IL
#7
This however was not the case and i no longer have a use for Summerboard (i manually mod my icon's as it saves crashes/slowing down). I upgraded/jailbroke/patched springboard with the 1 click iFuntastic method.
Ive been reading this forum and ModmyiPhone a lot and still cant figure out how to make my own icons and get them to the iPhone. I currently have iBrickr. I am good at photoshop and would love to be able to get this going but I don't even know where to start.
From my reading I think I may have it partially figured out but Im scared to try it.
When loading custom icons, you don't load a theme, right? You just replace the icon.png in the folder of the app you want to change, right?
Im really interested in making icons as well as themes for Summerboard, but like I said...Im scared!

Thanks for the reply Stevonw.
 

Stevonw

New Member
Silver
Sep 14, 2007
560
0
0
UK
#8
Ive been reading this forum and ModmyiPhone a lot and still cant figure out how to make my own icons and get them to the iPhone. I currently have iBrickr. I am good at photoshop and would love to be able to get this going but I don't even know where to start.
From my reading I think I may have it partially figured out but Im scared to try it.
When loading custom icons, you don't load a theme, right? You just replace the icon.png in the folder of the app you want to change, right?
Im really interested in making icons as well as themes for Summerboard, but like I said...Im scared!

Thanks for the reply Stevonw.
No probs iMerlin :laugh2:

I also find replacing them manually (although more time consuming) will cause you less problems in the long run.

Are you using 1.1.1 firmware?

Yeah in most apps all you need to do is replace the icon.png file inside the application folder with the custom one u wanna use. There are exceptions on v1.1.1 where Apple changed the names of the icon (The iPod is a good example of this....it's now called icon-MediaPlayer i think).

other examples of so called "hidden" icons are the Photos and Camera icons, which are both located in the MobileSlideShow folder called "icon-Photos.png" and "icon-Camera.png".

If you need any further assistance then feel free to ask ;).

EDIT : Have you been able to gain root access to the iPhone (aka access to the Applications, System folders etc)
 

iMerlin

New Member
Silver
Sep 20, 2007
662
0
0
Algonquin, IL
#9
I am using 1.1.1.

Stevonw - so I can only do this for a phone not running Summerboard, right? Or can I change theme icons the same way? Im confusing myself!
 

Stevonw

New Member
Silver
Sep 14, 2007
560
0
0
UK
#10
I am using 1.1.1.

Stevonw - so I can only do this for a phone not running Summerboard, right? Or can I change theme icons the same way? Im confusing myself!
Hello again iMerlin,

U can do this even if you are running Summerboard. Summerboard seems to work in a strange way with replacing icons, as it used to replace the icons by the icons having the same as the Application Folders.

I think that again this may have changed since the v1.1.1 update as almost all the v1.02 themes no longer work on v1.1.1 in this way :mad:
 

cljack

New Member
Nov 9, 2007
1
0
0
#11
I see that when i removed the new summerboard it gave me a warning that when i removed it that i may not be able to launch 3rd party apps.

This however was not the case and i no longer have a use for Summerboard (i manually mod my icon's as it saves crashes/slowing down). I upgraded/jailbroke/patched springboard with the 1 click iFuntastic method.

Hopefully this can help others in some way :(
I have searched and searched and you are the only one who had a post about the summerboard 3.0a11 warning from installer.app.

Essentially, I want to uninstall summerboard 3.0a11 but I am afraid to do it as I have 3rd party apps on my iPhone. I have looked all over modmyifone.com and hackint0sh.org and no one seems to address this uninstall.

I have an iPhone 1.1.1, activated, jailbroked with CARNAVAL 0.7, unlocked with AnySIM 1.1.1 (that was included in the CARNAVAL batch script).

Can I just remove summerboard 3.0a11 and be ok or do I need to restore my iPhone to 1.1.1?

Thanks for your help!